Remote Console on VRM portal issues

HI all,

Tonight I’m experiencing some instability on my VenusGX – I noticed some of my ModbusTCP sensors coming and going.

I then went to the VRM portal to open up the remote console, but I keep on getting this error:

Read up a bit and found out about the http://venus.local/ method, which luckily works. Rebooted the VenusGX but still giving the same error in the VRM portal. I also logged out of the VRM portal and logged in again – same thing.

Is this something that “should” correct by itself, or is there something else I should do/try?

It is connected via Wifi, but I see the signal strength is about 60%. I have actually pulled through a LAN cable to the garage where the whole setup is, so might try to switch from Wifi to ethernet. Unfortunately, the garage seems to be a bit of a deadspot when it comes to Wifi – the alternative is to try and put another Ubiquiti access point there.

I can’t tell you whether the problem is definitely wifi related, but my Venus is hardwired and never gives me issues. Except when the main router unexpectedly shuts down (people messing with the plug), after which I seem to have to restart the Venus, otherwise it refuses to reconnect even though the network cable was never removed.

I didn’t know the venus.local method, I always just connect to the IP of the Venus, in my case. Remote console is too laggy for me.

As a rule I try to hardwire all fixed installations. The stability is just so much better, and if you are someone that cares about that type of thing, the ping is also less (about a third in my case, albeit already low).

I had this issue yesterday twice, for the first time in about 3 months. It sorted itself out.

No idea what caused it. I was under the impression its an internet issue.

There were some load issues on VRM today. A very long backlog. I believe it should be fixed now.

OK just checked again and the Remote Console works again – thanks all.

My wifi-connected Venus was pretty stable up to now – I would occasionally get a ModbusTCP sensor become “unavailable”, but never bothered me that much.

However last night was pretty bad - since I monitor the grid-side voltage levels in an attempt to check for a power outage, I found that when the sensors went offline, they would come back with a value of 0 for a couple of seconds, at which point my whole HA system would think that the grid is unavailable and would kick in power-saving measures.

Now I can definitely make the HA side a little bit more robust, but I think I will probably take the time and hardwire the Venus too.

Good day all.

First post on ET and brand spanky new to it all too, and full of glee at no longer stressing over power issues, the future, etc. This is something one cannot honestly quantify, the liberation.

So anyway, I’m having trouble accessing my Remote Console (on Chrome), here’s the lowdown…

We have a Cerbo GX, installed on Friday 27/05/22. Firmware v2.86.
I’m on MacMini desktop OS X El Capitan. 10.11.6
My partner is on a MacBook pro.
We use the exact same IP.
She can access the Remote Console on her device, using Goggle Chrome, version 101.0.4951.64
I cannot. My Chrome version102.0.5005.61
Also, whilst using Chrome I cannot see the ‘Controls Icon’ to the right of the time displayed on Dashboard.

I can however access Remote Console on Firefox. No sweat.

Is anyone else having this problem? What shall I do should I want to use Chrome? (oh, and I have cleared out my Cache)

What happens is this, see image below:


Maybe check it again. South Africa has been somewhat internetly-challenged today. I’ve been running on LTE all morning because my Fibre provider has difficulty…

Hi @plonkster
Nope, just checked, no change. This has been the situation since Saturday 28/05.

Not sure if it means something, for some of my reading up suggests it may, but on my ‘Device List’ page for the Gateway my “Remote on LAN” line is empty…

see if this does anything (adapted from here, after being pointed in the direction form here). I have no idea if this relates to the problem and do not know what unintended consequences might be from the workaround - so try at your own risk.

  • Type in chrome://version/?show-variations-cmd into the Chrome address bar.
  • Search for text: PrivateNetworkAccessSendPreflights/Disabled
  • If the feature is not disabled:

Workaround (Only to be used if the PrivateNetworkAccessSendPreflights/Disabled setting is not present)

  1. Open the Chrome browser.
  2. To enable Chrome flags, simply type in “chrome://flags” into the Chrome address bar.
  3. Search for “preflights”.
  4. Change the below 2 settings from “Default” to "Disabled":
  • Send Private Network Access preflights
  • Respect the result of Private Network Access preflights
  1. Relaunch (or restart) the browser.

Check all is enabled:

This is on http://venus.local/ while one the same Wifi as your GX device

Also check this setting:

VRM two-way comms does not affect this. If you have remote console on VRM enabled, and you set a password (or disabled it), it will work. On headless units (Venus GX, Cerbo without a display) the password check is by default disabled.

Also, I already checked his setup. I can access his remote console, as can the MAC computer next to him. Something specific is going on with this computer, or the firewall in the building.

Thank you all for your responses. I suspect it’s a setting on my computer somewhere, or a browser setting. I recently had my machine upgraded, more RAM, new SSD etc and since then almost all of the websites I always used are showing “Not Secure” warnings, plus some are now illegible…

These first three screen shots show the the Not Secure in that website bar, and a page that always pops up:
Screen Shot 2022-06-03 at 9.06.14 AM

And this screenshot shows a website I recently used, before the upgrade:

So I reckon it’s not the VRM, nor a setting therein…
Thanks again.

remove all the plugins from chrome and then check again.
You might have a spam or other weird plugin now after you got your PC back. Or a Virus :thinking:

just curious, did you try the workaround I posted?

Chrome 102 comes with some security settings now enabled as default that were not the case with earlier versions - these changes could break some sites and the workaround will be my guess for where to look for something like vrm appearing broken.

Hi @Village_Idiot
No, sorry, I have not tried your suggestion. Just been too tied up with other stuff. But will give it a read through and attempt…
I can also not access the VRM on my Samsung Galaxy as per this post… No access to VRM on my phone … so having trouble in general.

Ok, this may not be related, but maybe who knows.

My old Mikrotik router was hacked twice.

The hacker was a nice guy, he drew my attention to the router by diverting all and every browser in the house to alternative sites. The speed of the webpages on any and all browsers was beyond atrociously slow on Fibre.

When I eventually looked at the Microtik, there was a firewall rule where he added comments like:
“update the firmware, I used XYZ to access the router”,
“change your password” and
“if you like the help, here is my bitcoin account”.

2nd time it started again, I replaced the Mikrotik. Not fit for purpose.

But I had to smile at the cheekiness. :smile:

This is what I found following your suggestion:

Screen Shot 2022-06-03 at 1.07.19 PM

…and on “extensions” only this:

Not much.
At this point I may just ditch Chrome, due it’s lack of shine :laughing:

Incidentally, this is my current situation with Safari…

Screen Shot 2022-06-03 at 2.03.56 PM

And I’ve tried several approaches to VRM on Safari, but I’m trapped in Kabouterville. :confused: