Victron Multiplus II slow switchover

I have a rather odd thing now starting to happen. Twice today, with load shedding, my MPII took a little bit long to switch over to battery when load shedding started. This results in my unifi edgerouter dying, and all the wifi access points with it…

This happened once before, but I am just curious as to if this is expected or not?

The change over happens quite quick, like 20 or so ms.

Yesterday me and friends was talking about the same thing. We all are Victron users, and we spoke about the same thing. Before, we could not notice the change over, but lately, there is a noticeable change over time. Still super fast, but slow enough to mention it.

Yes, it is indeed “fast” still. But like today the lights dimmed much more than usual, the NAD hifi audibly clicked off and on, and the router restarted. My Dell screen stayed on etc. so it must depend on the power supply of the device.

I just find it odd that sometimes it is slower. Must be the black magic LOM (loss of mains) detection that is a bit slow sometimes? Can I upgrade my multi’s CPU? :stuck_out_tongue:

Jip, have noticed it a little while ago during this latest bout of LS. Also asked around off-forum, others noticed it too although they thought they were imagining it.

Our Marantz amp also switch off/on when the MP2 switch over. Not always, but most of the times. Its normal. But lately the change over is slower than “normal”

My rule of thumb, Anything with a dc power adapter, the effect is minimum, but with AC, you will notice!

This is super strange - I started noticing some switchover issues too (Multiplus 1).

I recall when Jaco showed me the first time that yes, some lights did do a brief flicker. But recently it is as if more lights in the house do it, and I have a smart bulb (Yeelight) which has twice entered a weird state after it happened (low power dim, some flickering - looks pretty broken until I turn it off and on again).

I also have a UPS connected to my Home Assistant PC and that one does quite a bit of buzzing for a second or two when the switchover occurs.

I find that it is load-dependent. Heavy load, the dip is deeper. Light load… hardly noticeable. Also depends on what the Multi is doing at the time. Charging the battery…more of a dip. Sitting idle with lots of excess PV… less of a dip.

What is strange for me is that this even happens when I am running on solar. Grid feedin at that point is zero, yet I still experience noticable dips.

Also running MPII but never noticed anything switching off and on with LS recently, only the light dip but that has always been present.

But question is, if its evening and you already running on batteries, why is there a dip at all? The 30w coming in from the grid shouldn’t make that much of a difference.

I have hardly any load on AC1 when this happens - or are you talking about total load in the house.

This morning at 0:05 nothing restarted, but at 8:05 I had a “big” dip again.

But is it the load that the MP needs to pick up from the grid (30W) or the 10-20ms that your MP tries to power the entire grid (Lots of watts) that is being shedded and its voltage drops through the floor?

Guess the easiest would be to manually trip your mains, see if it then happens. Then your MP would just be disconnecting from the grid, but the grid wouldn’t need to be powered.

Unless I’m just completely wrong here.

Have the same issue, it happens even when 100% powered from PV with nothing coming from grid (except the setpoint). When load shedding kicks in and I lose the grid, almost everything running in my household will shutoff; very frustrating having all my PCs/network restart as I work from home.

I thought it might be due to a high load on my 3kva (usually around 1500w), but I upgraded to a 5kva last week with the same issue.

I’ve taken to using node-red to switch to inverter mode 5 mins before load-shedding kicks in. Just need to figure out how to automate the import of the schedule as I’m still manually doing that.

I have the same intermittent issue, sometimes it happens sometimes it doesn’t.

is it not perhaps the grid code settings, there is also a tick box for ups setting which is supposed to speed up switchover but needs to be switched off if you use a generator with dirty waveform.

1 Like

This makes sense.
Possibly changes in how the MP detects the drop, hz drops off faster than v or vice versa?

If you have a “compliant” system you cannot run with the grid code set to “None”. My system is setup with the South African grid, and as far as I remember I cannot set any of the AC high / low config, nor the UPS tick.

Yip, nothing to change with grid code set to South Africa.


I briefly ran with my inverter grid code set to none; all kinds of weird stuff happened.

What is it that happened?

While I had Gel batteries, and was running the system for backup, grid was set to “none” and all was working as expected.
I changed to “South Africa” only because ESS required it once I replaced batteries with lithiums.

I’m off grid. :stuck_out_tongue:

but you are right, didn’t realize that option disappears when grid code is selected.