Venus GX IP address constantly changing

All was well for a couple of months and now my issues started again. I did post about this a while back but cannot find it.

The Venus GX device. What happens every so often, is that it would randomly change its IP address. This is really frustrating because when the internet is down, I want to access it directly through a lan cable which I have running from it to a router in the house.

For reasons unknown to me, this address changes quite a lot. It can be anything from - I even had some 169. something. something (cannot remember this now) at times.

Why is it doing this? Should this not be a fixed thing?

The other thing that is of immense frustration, is that when the latest address is chucked away, the only way to get the new one is to access it via Bluetooth through the VRM Connect app. Problem is that sometimes the Venus just disappears of the network, for hours at a time.

Is this normal behaviour? Am I doing something wrong? Is my device faulty or need some setting change?

Surely it shouldn’t do this when directly and permanently connected to a lan cable?

Please help a ID10T here as I am gatvol of this.

You can set it to a fixed address under: Settings Ethernet/WiFi

1 Like

Hi @Swartkat
The GX will get it’s IP from your network router. It has a feature we can DHCP which automatically assign the IP to any new device. The 10...* is a local IP range meaning it is internal to your network (LAN), while your ISP connection like fibre is your external IP (WAN - if you ask Google “what is my IP” it will give your WAN IP)

And while it will normally try to keep the same DHCP assigned local IP to the same device this is dynamic in nature so it can change.
Depending on the router that you have it might have an option to assign a static IP to the device you want, and it will then not give that IP to any other device. On my Asus you can get that setting under the LAN option.

The real reason is that your GX is loosing it’s connection. This might be that it is trying to connect to another router (I think you had a few in the house), so the best would be to use a wired cable if you cannot assign a fixed IP on the DHCP settings.

PS. There is a way to manually assign an IP, but that is problematic if you are not a bit of a network expert, so I won’t try to explain and troubleshoot that.

Anything that must/can be changed here?


What @Louisvdw said above - find out what the static range is on the router and set one of the static IP’s to your GX. You need to know the dynamic IP range and not use any of those.

A pic to help … IP Config set to Manual … you give it its address.


Indeed yes. 3 Routers all connecting to each other with lan, and then the final lan cable running from the last router to the GX.

So would you say I should first try to give all routers the same IP address (making it static)?

Because currently I think they’re dynamic each with their own name and passwords.

Could this be the issue?

No you cannot do that.
Each device in your network must have it’s own IP. They cannot share a IP.
Think of it as the name you are calling that device with. If they share an IP then both will answer which will clash and you cannot hear any one.

The DHCP device dish out those IPs. From your screenshots this show that the router is also the DHCP device sitting at
You must log on to this device and go to the LAN → DHCP settings. There will be a range it can dish out to devices. If you set a manual IP it must be on the same subnet (in short the same IP as the rest except the last number) but it must be outside on the DHCP range. I would not do this if I were you.
Rather try and see if your router has an option to assign the same IP with DHCP, and if not get that smart IT friend in to come assist you again. :smiley:

You have a very good memory! That friend of mine is will be here tomorrow. I will show him this thread because basically all of it is Greek to me. He should be able to understand this language though.

Thank you for your quick responses. I hope I can get this sorted tomorrow once and for all.

So do you thumbsuck this address or how do you decide on one?

And if I follow this manual route, then this should not happen again? Unless I swap the routers?

(Because I have this other problem as well in that my dedicated old laptop I use exclusively for VRM purposes does not want to connect to the wifi of the router in the garage where the Multi is.

I have internal fixed addresses, a range of them, that I allocate to devices I want to easily access.

DHCP for the rest, things like i.e. phones, devices I don’t log into etc.

**You could, dirty trick, set the Cerbo to:
IP Configuration to Manual
Set the IP address - as per your pick
DNS: Server
… till your IT friend arrives.

I’m sure to stuff things up, guaranteed.

I’ll rather suffer another day this anguish. And FYI, you’re also speaking Greek. :stuck_out_tongue_winking_eye:

You kinda sorta need to understand networking a bit.

I’ll give you the short version.

IPv4 (version 4 of the scheme), uses a 32-bit number as an address. It is neatly split into 4 8-bit “quads”, hence you always get 4 numbers with a dot between them.

In this scheme, three blocks have been set aside for “private networks”. These blocks are 10.x.x.x, 172.16.x.x, and 192.168.x.x. It is a bit more complex than that, but let’s keep it simple.

Home routers are called that because that is one of the things it does, it routes between you and the internet. On the inside, it will typically use a private range. On the outside, it will use ONE public address, which your ISP gives you. You don’t have to worry about that at all, just basics.

Routers typically use either a 10.something address, or a 192.168.something address. Rarely do you see a cowboy using 172.16… I digress. Your router is using a 10.x address.

You can decide how many addresses you need in your internal network. While the 10.x network technically has 16777214 addresses, most routers will be configured to use only a portion of this. 255 addresses. That means your network starts at and runs all the way to

There is a bit more complication: Some addresses cannot be used. The lowest one ( is the network address and cannot be used. The highest one,, is the broadcast address, and also cannot be used. The router itself has an address (typically this will be and this cannot be used either.

The rest, up to, are up for the taking.

Now we get to DHCP. Dynamic Host Control Protocol. So how this works, is when your mobile phone (or whatever) connects to the Wi-Fi, it says, hey, my name is John, hand me an IP address! And then the DHCP server allocates one. This DHCP server is also built into that fibre/adsl/whatever router of yours.

You can usually tell the router which block of addresses it is allowed to use for this automatic allocation. It is common to leave some addresses open for “static use”. For example, in my home network, the DHCP pool starts at address 50. The first 40-something addresses are reserved for static allocation.

So how do you pick one? Well, you pick one that is between and, and ideally one that is OUTSIDE the DHCP pool (for this you have to go look on the router, how that is set up).

It gets more interesting/complicated. Why does it change?

Well, that IP address is borrowed from the DHCP server. You are allocated an address, but it is valid for a certain time only (typically 24 hours). When the lease expires, you have to renew it. This happens automatically.

The DHCP client will always try to renew the same address it got the previous time. The server will (depending on how smart it is) assign the same one again, if it remembers the previous allocation. But none of this is guaranteed. And after a power failure, or if there was an outage of more than 24 hours for a particular device, that device may get a new IP address the next time it tires to sign on, as the previous allocation may have been forgotten by then.

The other reason it happens… is because you have multiple DHCP Servers on the network. That has happened to me. If you have multiple APs on the network, you must disable the DHCP server in all of them except one (the “main” router).

1 Like

Disable Wifi on the GX then. If it’s already connected via LAN then this would help. I have WifI

Maybe this is why my issues started again. With installation of the larger inverter over 3 days I had to constantly switch between grid and inverter.

I will show all this to my friend that’s coming tonight, I’m sure he will make more sense of it.

Thank you very much.

Any idea on why the GX keeps disappearing from time to time of the wifi network?

I will do this also thank you.

And that is why my routers/wifi/network runs on a UPS - over and above the fixed IP addresses.

UPS was free, someone chucked it out … I just replaced the lead acid with a 12v lifepo4 battery.

If I remember correctly then you asked about Wifi Mesh before. A mesh router is just a normal router that links to another router on the network and you manage then as one. So everything Plonkster described is now managed by the mesh and the 3 different routers work like only 1.

This makes is much simpler for a normal user, but if you know networks you can set up any 2 or more routers from any brand to work similar. It’s just not that easy for the normal person.

To put this in power terms you can sorf of think like this as having Multiplus inverters in parallel and then adding a GX device to the set up to manage it for you.

Simple is always less complicated :smiley: so I always suggest that. If you can get away with only one router, then don’t get a second. And if you do and you don’t know networks, then get a Mesh router setup.

But in most homes 1 router should be be enough (just like 640kb :rofl: )

1 Like

If I don’t get sorted tonight, I will consider this option.

These mesh routers, do they link via lan or wireless? Cause my house setup is a bit of a problem for laying cables.

I also have a challenge with network wires … in the end I got so gatvol with multiple Wifi router issues that the “come-plaines” eventually made the wires go “through walls” … literally.

Read, I hardwired the Wifi extenders. Bugger this that they must connect to each other wirelessly …

Also learned that the more routers I installed to cover the areas, the more drama I got.

So I spent some money once … with help from an IT guru … and the problems went away.

Help worked like this:
IT Guy: Right, here is your problem, you are going to do this …
Me: Wait what, no, that is expensive …
IT Guy: Goodbye then.
Me: Ok ok fine. Geez man … just know I know where you live …

So IT guy did his thing and has not been back once, other than for beers.