Remote control of Goodwe ES

I have a Goodwe ES inverter. I can configure this from home no problem, and at current load shed levels and with inclement weather, I do need to tweak things occasionally - mostly the operation mode, put it into “economical” mode for a spell to force charge the batteries.

This is all OK when I’m working from home. I fire up PV Master and I can make the necessary changes. But in the new year I will have to start showing my face at the office again.

Now, some folks say there is a configuration facility available via SEMS that will allow me to remotely make the sort of changes I could make with PV master. Is that true? And is it only conditionally available? IE you need to be the person who actually registered the system on SEMS?

My first thought is if you can’t configure it remotely via SEMS portal would be to just setup a VPN and do the changes as needed?
Something like Wireguard has a iOS and Android mobile client.

1 Like

IIRC, you can configure mode and DoD settings over the SEMS app from your phone. Otherwise you can with a VPN and homeassistant with the experimental GoodWe plugin from HACS. PV master does not seem to work over VPN.

This is what I hear, but I don’t see that facility.

It’s why I asked about being the registrant of the inverter. I can’t register this inverter because it’s already registered to the installer.

Thanks. I shall look into this.

When I initially got my inverter, only the installer could do this via the SEMS app.

Nowadays, even a normal user can change the mode and on-grid DOD using the SEMS app on your phone. At least on android.

Go into the app on your phone, scroll down to the inverter, click on it. At the top of the list of parameters (underneath the graphic), there is a small button labelled “Configure” (it might be in a strange language). If you click on it, you are presented with a disclaimer, click on the already checked box saying you accept, and then on next. Now you should be able to change the settings.

I would post pictures, but it seems their site is down again, which is why I prefer homeassistant with VPN.

With homeassistant, you can also set rules to automatically change the modes under certain conditions or at certain times.

Yes. I had that all day yesterday. Most annoying.

Today there is a different problem. So, as you say, relying on SEMS is not the best option.

No. I don’t get that button.

The blue “Configure” button?

If you don’t get that, see if updating your app helps.

So I fired up the app and didn’t get the button. I uinstalled and then installed from scratch. Still no button.

Thanks for the help. I’m wondering if it doesn’t have something to do with who has the inverter registered on SEMS (clue: not me). It only really becomes a big deal when I have to return to the office. I’ll chat with the installer after the holidays.


Can you elaborate how you make changes in Home Assistant.
I have the integration, and can successfully change the DoD percentage. But try as I may, I cannot get to successfully change the Operations Mode.
I would like to change from Normal (On Grid) to Backup Mode when certain criteria is present.

Everytime I make the chance in Home Assistant, and then go to the PV Master App or Sems App, the change does not reflect.

(PS. as stated my DOD changes made in Home Assistant do reflect in PV Master)


Ok, so you have the option to make the change in HA, but it does not do anything? Usually after a change like that, the inverter has to restart, does that happen?

What version of the integration are you using?

First, lets start with the following.

  1. What is the firmware version as reported by SEMS portal of your inverter?
  2. What is the version of the HA integration you use. Built-in or custom+custom version?

The reason I ask this is this. With earlier firmware, like 2121 and arm 7 for example, as @_a_a_a mentions, the inverter requires a reboot to change from general to eco_charge as an example. As in, the mode will reflect in PV master, but it won’t take effect without the reboot. In later versions, such as 2323, this is no longer required, you can change the mode and it will take affect without a reboot. A massive improvement in my opinion.

The master branch of the custom integration actually now support eco mode v2. This only works if your version on SEMS read 1242417 (latest as of Q3/4 2022). What this mode allow for, is to say, charge the batteries from grid up to 80% SoC then stop. This is nice to prevent the batteries going to 100%. If I had no solar panels, I would leave the inverter in this mode in fact.

That is a good way to ensure that your cells never get balanced, and would most likely void your warranty if you have pylontechs…

So say we all.

If one is skittish to go to 100% SOC because of “issues”, then fix the issue, don’t “hide” it at 80% SOC.

1 Like

That is what seems to be the problem, the restart does not happen (as it would if you make the change in the app)

If I look at my PV master app, I can see how it changes from On Grid to Backup Mode as I toggle the input on the integration. This happens like in 4 seconds

But the problem is the inverter does not restart. So the change does not take effect.

I do not know which HA Integration version. I assumed the latest because I installed it 2 weeks ago.

I did ask for Goodwe to install the latest firmware and ARM firmware which they said they did today and I can see I am on2424G firmware.

This did not help

Not as bad as leaving them on 100%for weeks when we had 0 loadshedding. Either way doesnt matter I have panels so they go to 100% daily

Get your arm firmwares updated.

That said, what do you expect in backup mode?

I found now on the 2424 version, backup mode doesn’t charge battery from grid anymore like it used to on the older 2121 Firmware. You need to use eco charge mode to charge from grid.

For reference, I learned some things I thought was the case, but I was wrong, from Inverter ES 5048 · Issue #164 · mletenay/home-assistant-goodwe-inverter · GitHub