MPII 3kva issues when on generator

System: Victron MPII 3kva, 2x pylontech us3000, victron venus gx controller
Used as a UPS at my office. Load: networks switches, servers, routers, laptops and PCs. About 500w at night and 1200w office hours. The system works perfectly well as ups generally.

We moved to a new building which has a 100kva three phase generator, which started getting regular workouts due to the current level 4 loadshedding.

The first problem that cropped up was that the battery charging circuit could not regulate the charging process well when powered by the generator. Result: battery overcharged, voltage reaches 53.8v and the inverter shuts down.

To counter this, Jaco switched on a setting which detects when the battery is too high, and dumps the excess power back into the output. This lowers the battery voltage again. Seems like a good solution, but it caused a different issue:

The inverter shuts down with a overload error. At first I thought it was a load issue, but then realised that it only happens on the generator. I watched the venus display closely and saw the overload light flash while the load is constant 600watt.

When the inverter sends power out to discharge the battery, it also sends it out on the one phase of the generator. I suspect that the generator doesnt like it when one phase gets power back from its load while the other two are still supplying power. It causes frequency instability, while the victron inverter is trying to output to a stable frequency - and I assume the two go out of phase so far that there are serious current spikes leading to the interter overload shutdown.

How do we solve this?

I can think of one solution but would not know where or how to program it: rather than pushing power out to discharge the battery when its voltage gets too high, disconnect the input and run on the battery to drive the output. Run down the battery to a preset level eg. 40%. That should last longer than most loadsheddings, and even if you then switch back to the gennie, the battery voltage will be so low that it will be a few more hours before it gets too high again.

I would recommend updating the firmware first.

The problem i see with the issue above is that your system cant know if its running from generator or grid. With a Quattro you have 2 inputs and both ouputs can be configured differently. With the Multi having one Input this is not possible. Setting it up in Hub1 or with an Generator Assistant using an contactor, you will have additional cycles on your batteries as it will also follow the rules when the grid is available.

The second best solution is allow the battery to remain at 90-95 % to ensure that the batteries dont go over voltage. We will speak in the morning to try and get a time to change the settings.

It tripped again last night, so I have to go in early to restart. :unamused:

The problem is an unstable input voltage. The Multi has to control the voltage of the battery by adjusting the PWM signal it drives the transformer with, and as you can imagine, if the voltage is not stable, then it is always playing catchup, a little energy slips into the battery, then out of it again, it is never symmetrical, etc.

The setting you turned on allows an overvoltage to be fed back into the grid. So if the battery is 0.4V higher than it should be, the Multi will feed that back into the “grid”. Of course, if the grid voltage sags while it is doing this, then more energy might feed into the grid than was calculated, and in extreme cases that could cause an overload.

So to fix it, I suggest not letting the battery get full.

And also, it would be interesting to know how badly the voltage swings. One of the interesting cases I’ve seen is a PV-inverter and cloud-edge effect pulling the grid voltage up by 5V in a very short space of time, causing very full batteries to overvolt.

These things also only happen when you have the ESS assistant installed. So another thing to try might be to stop using ESS. It’s a UPS after all.

I realise people install ESS to work around another pylontech quirk… that it needs to see some action every two days, or it raises an internal error warning…

So, I am having this exact issue:
System: MPII 5kVa, Cerbo, 1 x Pylon US3000c as a UPS. Output was about 650 watts.
Had an extended Eskom outage and was using a 60kVa 3 phase generator to power everything. Once the Pylon was fully charged, it went to over voltage and BMS shutdown battery and also the inverter. Tried limiting voltage on DVCC to 51 volts, but inverter kept on charging up to 54 volts. Tried limiting current on DVCC to 0 Amps but inverter kept on charging. Seems like DVCC was being completely ignored and Pylon was unable to limit inverter as comms cable is installed also. Using firmware V2.72 on MP. Has this issue been solved on FW V2.74? Is there a way to stop the MP charging via VRM remotely? I was offsite when this happened and was unable to stop the over voltage. The problem was resolved once the generator switched off and Eskom supply restored. Even the DVCC limits worked.
Disclaimer - I am not an electrician/ engineer. Everything that I learnt about solar was from forums, the internet and fiddling with my equipment…

Remove the ESS assistant if you are using a generator during extended outages. I know that’s not the best or easiest answer, but when “running grid-parallel” on a fluctuating voltage, this sort of thing unfortunately happens and I am not aware of any easy fixes.

Thanks Plonkster. At least I now know the limitations of my system and can work around it. Currently, I am only using ESS to be able to see the critical loads and total consumption from the Carlo. However, panels are being added in the next few weeks. ESS is “higher grade” stuff and I have not yet had the need to fiddle around too much with it. VRM gives you the options of “Optomised with battery life” and “Optomised without battery life”. Do either of these options give you a way to limit the charge to a predetermined value (eg. 90%) when needed. My current ESS setting is to keep batteries charged. So, basically, I am asking if you can configure the battery to only charge to a certain percentage from VRM or if this setting can only be changed on site using the cable (like Jaco mentioned in post 2).

You can upload a new config file from vrm… Don’t need the cable anymore. On VRM you will see the device list. Below it you will see a button “Remote configure”, download the file, make changes and send it back.

If you don’t feel comfortable to do it, I am willing to help?

1 Like

Perfect, thanks Jaco. My generator is only used for extended outages. At least, I now know that it can be done remotely if needed in the future.

1 Like

Exactly. Without ESS the pylontech’s buzzer starts beeping because it never discharges. So we really don’t have a solution to this. And I see new loadshedding comin up soon.

Technically, you need to cycle them daily or you lose your warranty…
image

I believe updating the firmware takes care of the alarm. We should try it and test without ESS…

1 Like

We removed the assistant from our favourite Customer in Bellville area (not the other Jaco) and I haven’t heard any complaints…

Different model batteries, newer models seems to come without the alarm issue.

1 Like