CBI Astute - a high current WiFi switch with Power Monitoring

Sorry to bump this. Just wanted to say I found a couple at the Builder’s Warehouse Faerie Glen in Pretoria (Atterbury Value Mart) – still at R349 a piece.

They’re in the locked electrical cabinet where all the other circuit breakers are. No price against them but I did a price check and it is indeed R349.

I’m surprised there’s still left. I was told that each BW will only get 4 at the ‘special’ price. Lucky I still have lots of them, more than I’m likely to need.

Anyway, coming back to my ‘EMP’ event. I eventually figured out that it’s more of a Tasmota issue after the device went offline again after a thunder storm. It turns out that Tasmota will reset its settings if the device is power cycled a few times in a certain period. Apparently, brown outs can also cause this to happen. I realised this after the second time when I saw the hardware was ok, but the software was ‘corrupt’. The clue was that the device broadcast its own SSID and that’s when the penny dropped.

In order to prevent this, you need to run SetOption65 1 to disable power cycle setting reset, so it is less sensitive to brown outs. I’m holding thumbs this is now resolved.

It worked for mine. Never had a reset after that.

1 Like

An issue I’ve picked up, it seems one cannot install this app on a pc? It is apparently only available for Iphones? Is this correct?

See screenshot below of what Google Play tells me. Is it at all possible to control this unit from your Windows pc?

And when I try from the Apple Store, I get a message that says this app is only available for Iphone.

In general you can’t install mobile apps on x86 based PCs.

Ok so noted. Didn’t know this is only a mobile application. Thanks.

Yeah only Google Play(Android) and App Store (IOS)

That’s why we either setup tuyalocal and control it from Home Assistant, or install an alternative wifi chip and flash it with Tasmota and control it from Home Assistant.

Speaking of flash, you’re not perhaps able to flash an Ipad of which I forgot the apple id?

Not entirely sure, but I presume flashing to be clearing a device of its operating software and installing something else?

Sorry to bump this one…

I see there’s a new CBI Isolator switch now available CBI Astute Smart Isolator (ASI) | CBI-electric (Circuit Breaker Industries) (cbi-lowvoltage.co.za)

I’m guessing this would not work for an stove/oven, since my existing isolator is 60A?

Your Isolator might be 60A but the breaker feeding your Stove seldom exceeds 30A.

Just check in the DB,

1 Like

Checked it this morning - 45A breaker. It is a double oven (one turbo-fan with grill), as well as a 4 plate stove, so I guess turning it all on simultaneously could be more than 30A?

A later model of the defy oven states 22A: Defy 184L Gemini Gourmet Multifunction Double Oven

Realistically speaking I’m never going to turn on it all, but probably not a good idea to install something under-specced.

You could just install a 30A breaker in the place of the 45A one.

30A is roughly 7.5kw. Oven elements are normally between 1.2 and 2 kw. Exceeding the 30A would be difficult. As @plonkster said, drop the breaker to 30 and install the Astude. I am pretty confident that you wont exceed the 30A.

If the device is Tuya based, even if it is sealed it can be flashed using the Tuya-Convert process. I have a few of these (or similar as the Takealot link does not work anymore) plugs and flashed Tasmota on quite a few for a friend as well.

As a side note, if you use Tuya-Convert you can roll the device back to it original firmware…but who would want to go back to the cloud?

1 Like

AFAIK many of the loopholes for Tuya-Convert has been fixed, so a lot of the plugs for example are no longer flashable with it.

There’s also some indication that they’re switching to a different System-on-chip which isn’t compatible with Tasmota :frowning:

There was one guy who opened his CBI Astute and switched the Wifi board inside and loaded Tasmota – but it involves breaking the seals on the thing.

Yes you are correct, but as far as I understand mostly applicable if you update the firmware. To date I have not had any issues and the wizards maintaining Tuya-Convert is doing a stellar job to keep it working. Worst case is to crack the device open and flash it.

I have “enhanced” the CBI Astute using that tutorial. I don’t recall any seals though. Super easy if you have hot air.

I have personally never used Ewelink or the Tuya app. When I get these devices they get flashed straight out of the box. I feel more comfortable running an opensource firmware and have full control over these devices. Might be a false sense of security, but works for me :grin:

1 Like

Honestly, neither have I. I used a Tuya dev account and registered the device via CLI, then proceeded to block in on the router.

But still, I would be 1 step more comfortable with it running some nice open-source software and being completely oblivious of outside servers.

OK, I lied, I ran the original eWelink for 2 weeks with my first Sonoff. Then they had “AWS problems”, I couldn’t turn on my borehole, and I learned about Tasmota.

1 Like

I got my hands on one of the new wall plug installed Astutes.
Works great (obviously) where you want to control/monitor a single plug circuit and not all the plugs as you would with the DIN rail mount version. As well as the usual momentary button to engage or release the relay, it has in addition a push button power switch that kills the power to the electronics so it is not even on the wifi network.

This is awesome! Where did you get it? I’d like to see this for light switches as well.

What I have come to notice, and would love to learn whether this is a common issue amongst members that use these, is that that these CBI Astute Smart controllers are very finicky when it comes to switching their scheduled program times on and off.

For example, when I don’t want the geyser to turn on at 04h00 in the mornings on a weekend because we are not home, I will turn that “switch on at 04h00” setting off.

Turning it back on for the coming week is of academic value only, as it simply does not activate, even though it shows as on.

You have to physically remove that scheduled program and re program it in that time slot.

This is has now happened 4 times and I believe it is a software fault/glitch.

Since I’ve had the unit (more than a year now), there had not been a single update to the app.

Anyone else experiencing this?