Windows 11 Pro on Raspberry PI 4

Hi All, I am setting up a RaspberryPi for a test bank and loaded it with Ubuntu, I have a Hantek 2 channel scope connected to the system and want to use the PI for the Arduino IDE as well.

It took me the better part of a day to make everything work. Its easy to install the IDE on the normal version of Ubuntu, but different and a bit tricky to get it working on the UbuntuArm version.

After searching for ever to get a proper Linux version of the Hantec software , I found a copy and with the advice from @plonkster, I got it going.

I still cant get RealVNC going on this combo, All the available .deb packages I can find, complains about missing dependencies during installation, so i gave up for now. I would like to install RealVNC to be able to continue with programming from home, without traveling my projects up and down between work and home.

So I searched and found this page. Installing Windows 11 on Raspberry Pi (An Illustrated Guide) – RaspberryTips

I decided that I have nothing to lose and tried it. To my surprise, it worked. I used a very old Raspi 4 with 4 gigs of ram. (8 gig recommended). Although al the processes are automated and very easy to follow, it takes time, About 2-3 hours depending on your connection speed and the storage device you chose. I also used the Windows installation method as I did not want to setup a pi and use the first installation method from this page.

All and all i say it is well worth it, and I can see there was a lot of work done to port this correctly to work on an Arm processor. I am truly surprised by the smooth operation once loaded and set up. I downloaded a couple of software installation packages (For Windows) to see if it will install correctly and had no issues whatsoever to get them going.

I am going to look for a Raspi 4 with * gig ram and repeat this process with an Nvme SSD to see if there is any performance gain.

1 Like

What do you guys think about this unit.

One Issue I have picked up so far, I cant seem to get the second screen going and the system only detects one.

tigervnc or remmina would be a better choice in this context (IMO).

I would be surprised if you can get the Hantek software working on arm at all. Have you had a look at the intel based odroid boards or a lattepanda?

1 Like

I think he is using some kind of opensource software that supports the Hantek. OpenHantek?

Sometimes it is quite possible to get the original (usually windows) software going on Linux, but one obstacle that is often missed is that even if the software runs fine under Wine (the windows “emulator”), people forget that Wine is actually not an emulator. The acronym is quite literally, in the usual recursive style, short for "Wine Is Not (an) Emulator :slight_smile: ). Wine only replaces the WIN32 system calls. That means software made for an intel processor won’t run on ARM… regardless of OS. Anyway, thought I’d throw that in for full info.

In any case, the issue here is that the software needs access to the USB port to access the scope, and the deep technical details of telling udev how to do it… that is all I helped with and can take credit for. Jaco figured the rest out for himself and I don’t even know how and where he found the stuff :slight_smile:

Got it going, if you ever need to do it, just shout. Used OpenHantek, add the rules file (Supplied) to /lib/udev/rules.d to give the Hantek access to the USB Port and it works. They even wrote a User manual for the Hantek6022-BE and its seems pretty stable.

1 Like

/etc/udev/rules.d is the other location, which is where user-added stuff should really go. On a technical level it doesn’t matter where you put it, it is more of a “policy” thing in most distros.

The reason why there is two… well some distros take the FHS (filesystem hierarchy standard) serious, so it cannot be any other way :slight_smile:

If that is on Windows, you need a 2nd screen port … if I understand correctly.

The Pi has two ports, it works with any Linux / Ubuntu based OS. The Windows 11 ARM version dont seem to see the second. I have tried a few things, but cant get it to see the second port.

someone who (youtube vid) seems to have gotten Windows 10 dual monitor working on a Pi. might be some useful info there (also check through the comments)…

something random to check/experiment with. On my PC based windows 10 (yup I know it is no 11) after some “monthly break your machine and help us find what we did wrong moment” (i.e windows securityupdate) my PC would boot but no longer output to my previously preferred main monitor (connected via Display Port) and no amount of keyboard/mouse clicking would do anything. Finally figured out that windows will no longer wake up the monitor from standby power - I have to hit the power button on the monitor BEFORE booting the PC (in this scenario there is a second, also powered off monitor connected via HDMI - this monitor also displays nothing, unless I hit the windowsKey+P to cycle through the output options). If the second monitor does not have a power button maybe try disconnecting/reconnecting AC to the monitor/s just before booting the Pi.

1 Like

What is strange is that the Standard PI square colored block appears and remains on the second screen as long as the Pi is running. This tells me the PI sees the second screen and outputs to it, but windows does not see the second HDMI Port.

I am literally the last person to advise about these things:
But I had occasion to add a second screen via an HDMI recently.
Pressed the “windows key” simultaneously with “P” and selected “Duplicate”.
And that, sir, is the extent of my knowledge on this subject.

1 Like

Did you really have to post this here… I like the specs… And then I saw models for up to R12k… And there the internal struggle starts… The R3k is all I need, but what is the difference… And I don’t plan to buy again next year…the R3 k will work? But the 12k will work better, right???

I use to be a gamer, and although the currently installed GPU is capable of playing games ten times more power hungry than the ones I love to play, the latest model is just so attractive…

Man… Why???

I used to love the Pi’s - cheap, basic, SBCs. But recently the price is just ridiculous. Have started using Intel NUCs now, and they work out cheaper, far more reliable, and you can run whatever software you want on them with no issues.


I just got to the level of what …bugger the effort, just virtualize it all where possible (Hyper-V), and use the one piece of hardware for more than for just “one” use.


I think if you are moving towards that price range, a second hand (or perhaps even new) NUC is much more bang for buck, but I haven’t really paid much attention in that space recently.

1 Like

Intel is stopping the manufacture of the NUC, but they encourange OEMs to keep making them so soon there will be no more new NUC PCs for sale.

Yup. I see the basic NUC6/NUC7 celerons are disappearing fast. Used to be able to pick them up for around R2500.

I see some new manufacturers becoming available though, so hopefully we will see some cheapies again soon:

Nee man, julle maak my deurmekaar…

I have an OEM windows 10 key, 2 days after installing it normally prompts me to upgrade to 11. We bought a few laptops for work and had it upgraded instore, so now i am sitting with 5 x 256gb M.2s and 8gig ram modules in a box, unused. So my base cost on this is the advertised R3.8k… And it seems like a powerful little toy.