VRM displaying wrong data


Something weird is going in with my installation’s data on VRM.

I am running Venus OS 2.7~3-large-12 (venus with node-red) on a raspberry pi 4 with a can hat.

Here is two screenshots, one is of the local console and the other the exact same time on VRM

The VRM display is stuck on that data. I first started to have the problem when I had to replace a faulty Raspberry Pi running venus. I had to replace the raspberry pi and can hat. I think that was the last data the faulty pi reported. I have replaced the installation as per the instructions in VRM. Yesterday I completely deleted the installation rebooted venus and added a new installation from scratch still the same incorrect data remains.

Does anyone know what might be causing this and/or how to fix it. VRM is totally useless to me now.

The VRM will timeout if you leave it on the dashboard for too long. This is to save you data usage as the new realtime data use much more data than before. It’s a feature, not a bug.

All you need to do is refresh the page and it will know you are watching again and display updates.
More information at


Unfortunately I don’t think that is the issue, here. The data it is reporting is from 3 months ago… :upside_down_face:

If I refresh the page VRM shows the correct data, but in an instant it is replaced by the “wrong/old” data. Sometimes when I stay on the page it corrects itself only to go wonky again later. Also to note it always shows the same data as ons the vrm screenshot.

That is how I picked it up in the first place, I kept seeing my Battery SOC was 98% even though it was 11PM…

Are you sure you are accessing the right site?

The site is identified by the VRM id, which in turn is created from the ethernet address of the Pi, which in turn is created from the serial number (passed by the boot loader to the kernel when booting). If you replaced the Pi, then the VRM id would have changed. If you also deleted the site completely, and then re-claimed the new VRM id (which is really just a 48-bit ethernet address), I cannot see how it would hold on to the old data.

You could try deleting it again. Then reboot the Pi once (so it announces itself again), and then claim the site again.

If it still persists, send me the VRM id and I’ll use my considerable influence to get it looked at… :wink:

Hi, yes quite sure, I initially accessed it using the old link and it said permission denied or not found error. It then showed the new site under my installations. I can see the vrm portal id looks like a MAC address, by doing a mac lookup it confirmed my suspicions.

Raspberry Pi Trading Ltd

I will remove again and reboot and add and will let you know.

Thanks. :sunglasses:

Ok tried again still the same…

What is weird is sometimes after a few minuets of just staring at the portal the data corrects, also I have not seen the “Realtime” indicator since my issues started.

Another anomaly I spotted today was that partial data started to populate correctly, like the PV Charger and Battery SOC whilst the Grid and ac loads where misreported.

@plonkster I have sent you a pm with my vrm portal id… If you could maybe wield your considerable influence, :stuck_out_tongue_winking_eye: