Victron Quattro not feeding excess back to grid

Up to about 6 months ago, my Quattro use to feed back to the grid. I started to get high voltage errors and was informed to lower the bulk charge voltage. That stopped the high voltage alarms, but broke the excess feed to grid. I reverted the change without any luck.

I would appreciate any advice to try resolve this issue.

My system config is as follows:


Name: Victron Quattro 8kva 48v

Batteries: Gel 600ah

Colour controller.


2X Bluesolar charger MPPT 150/70

ESS config:

Mode: “Keep batteries charged”

Grid Feed in – AC-coupled PV – Feed in excess: Enabled

Grid Feed in – DC-coupled PV – Feed in excess: Enabled

When the ESS is set to the above config. I.e. Keeping batteries charged. It will start to pull the entire load from the grid, regardless of batteries being 100% and stop PV generation. Hence set to optimise batteries.

VE Con config: (Currently set to optimise batteries)

Change keep batteries charge to Optimize with battery life 95%. I am almost sure that will solve your problem.

Lowering the charge voltage should not stop feeding in of excess PV. Presumably you mean excess DC-coupled PV.

The way it works, is that the solarchargers are instructed to charge 0.4V higher than the Multi expects. The Multi is told to feed in any voltage higher than what it expects. The battery then ends up in this 0.4V window on top of whatever charge voltage you’re using. It shouldn’t matter if you lower this, the mechanism should still work.

I also assume you used the DVCC charge voltage setting on the GX device to set the lower charge voltage, and that the solar chargers are controlled by the GX device.

Dear Jaco.

Unfortunately this didn’t seem to work.

Dear Plonkster.

Thank you very much for taking the time to respond.

I agree, I don’t think changing the voltage causes it. Possibly the processes did. I downloaded the file from VRM. Opened it with the VE con. program and made the change on the 4th screen above. Then proceeded to upload the file. When opening up on the app, it did request to perform an update. I did not make any changes directly on the colour controller for the DVCC

Your assumption are correct as the chargers do appear on the colour controller and it did work beautifully before.

The DVCC settings are as follows;
DVCC: Enabled
Limit charge current: disabled.
Limit Managed batter charge voltage: Disabled
SVS - Shared voltage sense: enabled
STS - Shared Temperature sense: Enabled
Temp sensor: Automatic
SCS - Shared current sense: enabled.
SCS status: Disabled(External Control)

If any other setting would assist, I would gladly share. Thank you once again.

@JacoDeJongh or @plonkster or @anyonewhoknowstheanswer ( :nerd_face:) will changing the charge voltage on the quattro without changing the charged voltage on the BMV have any effect on ESS operation?

ESS will use one of the settings… so change that source of info for it…The “Controlling BMS in DVCC”.

Hi, did your issue get resolved?

That voltage just tells the BMV at what point it can begin to count towards auto-resetting the SOC to 100%. It has no effect on ESS.


Unfortunately nowhere closer to having this resolved.

You need someone to look at this. Unfortunately I am completely snowed under and this is not an official support channel… so I cannot look into this right now. All I can say is that what is supposed to happen, is the battery should charge 0.4V higher than the voltage you set (it would help if you can check this), and then the Multi should attempt to feed that 0,4V in… assuming something is not preventing it from doing so.

Not to stray too far off-topic and cognisant of there being other support channels. How does the GX device determine SOC in an unmanaged battery (purely voltage, internal current sensor of the Quattro) ?

Reason I asked about the BMV is that OP has GEL batteries and looks to have changed charge voltage of the Quattro via VE Configure. The ESS manual mentions “Feed-in will only occur if there is sufficient surplus PV production to fully supply the loads, and the battery is charged (or at it’s charge current limit)” - (bolded my emphasis). Also, the CCGX manual DVCC section indicates MPPT controlled by inverter/charger setpoints. So, I was wondering whether the GX (MPPT?) is waiting for either a SOC that doesn’t happen because BMV “charged voltage” is not updated or a specific battery voltage that does not happen because the Quattro voltage was changed via VE Configure.

Unmanaged, then it uses the internal sensors in the Quattro. There is no DC shunt in the Quattro/Multi, it is estimated from the AC values. If you have a solar charger, the current from the solar charger is communicated to the Multi to make it more accurate. What you get is ok, but less accurate than you would get from a proper battery monitor (such as a shunt, or a BMS). Which is why it needs to be fully charged to sync to 100%, otherwise SOC drift will occur.

However, Feed-in of excess happens ONLY on voltage. If your battery hits absorption voltage at 85% (which is what lead acid does), you want the surplus to go into the grid from that point onwards. It doesn’t wait for 100%. It doesn’t even look at the soc to make this decision.

There is ONE issue that happens frequently, typically to people with small batteries. They set the MinSoc too high. For example, if you set the minsoc to 90%. If the battery is below the minsoc, the Multi is turned into a lower-power mode. The Inverter component is switched off. This means that instead of the ±35W drawn normally in no-load conditions (by a 3kVA unit), it needs only about 18W. Useful when the battery is below where the user wants it. However… in this condition, no feed-in can be done. The inverter component is off.

Now a mistake that people with lead-acids make, is they set the minsoc too high. What happens then, is the solar chargers throttle back (because the absorption voltage was reached), but no feed-in happens (because we’re below minsoc). For lead acid batteries, don’t set minsoc below 85%. WIth lead acid, the voltage can be up high while the SOC is still quite low :slight_smile:

Replying to myself. The OP said he has it set to “Keep Charged”. Which means all that stuff I typed about minsoc set too high does not apply. Something else is going on. Either…

  1. Solar chargers are not raising the voltage by that extra 0.4 (should be easy to verify)
  2. The charge voltage is raised, but the Multi refuses to feed it in (this one is hardest to debug), or
  3. There is a calibration discrepancy, and the Multi measures 0.4V lower and simply doesn’t see it and therefore does nothing (but he has SVS on, which should eliminate that, so again… probably not this one).

If you would like me to look at the config, you can invite me to the vrm site. PM me for my email address. Also if you have pictures of your setup to make sure all is well.