Victron Multiplus II Temperature Warnings


I have a Multiplus II 5kVA unit (hardware revision 5, configured as part of an ESS system) that is reporting temperature warnings from time to time. Below is the screenshot of the VE.Bus Warnings and Alarms for the past 30 days:

The highest ambient has ever been is 34C, but it hovers around 30C on most days. Airflow around the Multi is not obstructed:

The warnings coincide with heavy loads either at the input or output side, and it running at capacity. I find that it derates to 3700W very soon after a heavy load (e.g. geyser) is switched on. I’ve never seen it derate lower than 3700W though. The fan turns on whenever the load exceeds about 1kW, which is most of the time. When the fan is blowing I can feel a slight draft at the intake vents at the bottom but the airflow at the top exhaust is barely perceptible. The top exhaust grille also feels very hot to the touch under load - almost too hot to touch, so I guess close to 60C.

Is what I’m seeing normal, or is something amiss?


P.S. Something else that bothers me is the barrage of overload warnings being logged. The grid is (almost) always available, so there should be no reason for it to go into overload.

P.P.S. Ignore the low battery and DC ripple warnings - the batteries were temporarily disconnected during a firmware update to revision 478 (the latest).

Hi Pierre, Welcome here. Can you please give me the serial number for this unit?
When did you buy it and when was it installed?

Hi Jaco,

The serial number is HQ20081FNVG. It was purchased on 14 May 2020, and installed in June 2020.

Thanks for looking into it.

There goes my first suspicion. Up to mid 2019 there were some Multi’s send out with a manufacturing issue, they had these exact alarms, but that was rectified by about HQ1924XXXXX.

The constant overloads are a bit worrying to me, the temp might be due to many reasons. How big is the room this equipment was installed in.

The overload warnings occur when a large load is switched on on both the input as well as the output side. I can sort of understand the warning if a load > 4kW is switched on on the output (even though it has a 50A transfer switch), but it really should not go into overload for a load on the input side (like the geyser).

The inverter is in the laundry room which is about 10 square metres, but there is no door and the passageway leads to the rest of the house. Consequently even with the heat generated by the SmartSolar and the Multi, ambient there is quite close to ambient in the rest of the house (perhaps +3C at the most). We’ve been having hot weather lately, so 30C is not unusual.

I assume you have a Carlo on the grid side that allows you to send power back to the input of the inverter, if that is correct, the unit work just as hard sending 3 kw to the input side and 1 on the output as it would work to send all 4 kw to the output. So sending 4 kw in either direction takes the same effort and it will generate the same heat.

It still should not report so many Overloads, @plonkster ?

That’s correct. As an experiment I’ve now set the “Inverter Power Limit” setting to 4kW in the ESS menu. I suspect this might take care of the overload warnings (at the cost of marginally increased grid power usage), but the real concern for me is the temperature warnings.

I think a nice feature for both the Multi and SmartSolar (which also gets hot) would be to have user adjustable power vs temperature curves, or at least the option of being able to select between a few presets. In my case I would like tune the power throttling to be a bit more aggressive, so the inverter runs cooler and (hopefully) lasts longer.

I believe the cause of that issue was found recently, but I don’t yet know if a new firmware with a fix/workaround is available yet. Perhaps make sure you have the latest firmware first.

If the device raises an overload warning (not alarm) and doesn’t switch off, I would just ignore it. It is not serious, it’s more of a pre-alarm related to the power pack working a bit harder than it should.

I am on the latest firmware (478).

I’ve had the “Limit Inverter Power” ESS setting to 4000W for about a day now. It’s perhaps too early to get excited, but so far I have not had any overload nor temperature warnings.

I’ve noticed that without limiting the inverter power that under full load it generates about 4400W for a couple of minutes, before dropping back to either 4000W or 3700W.

All the temperature warnings seem to occur when it is running at 4400W. Perhaps the inverter is too slow to react to the rising temperature? Given that it is only rated for a continuous 4000W, I would expect it to throttle back from 4400W well in advance of the temperature becoming an issue. Is this the firmware bug you are referring to?

Thanks for your help!

1 Like

It is normal for the Multi to derate to 60% of its nameplate rating when it runs too hot. The rest of the time, it runs at 80% of its rating (the nameplate rating is the off-grid rating and is more of a peak value, it cannot run at 100% for more than an hour or so, depending on ambient temperature). Your numbers are a bit weird, I’d expect 4000W decreasing to 3000W. Maybe some things changed that I am not aware of… but in any case, a bit of derating when things run hot is not abnormal.

No, I was thinking of a different issue. Sometimes the Multi (at least some of them) raise an overload warning while it is running grid-connected. This should of course not happen, while running grid-connected the difference can just come from the grid and there is no reason that the Multi should need to overload itself, so I know this is something the firmware guys were chasing. But as I said, if you know what causes it, and if the inverter does not actually switch off, it’s at best a small annoyance.

According to the spec sheet it supports continuous output power of 4000W at 25C, 3700W at 40C and 3000W at 65C.

The overload warnings I am not too concerned about, but I am not comfortable ignoring the temperature warnings. I need this inverter to last a very long time.

The behaviour I am seeing when a large load is switched on is that it runs at 4400W for a while until it overheats, emits a temperature warning and then dials back to 3700W. Surely this cannot be right, and points to some kind of firmware issue? Limiting the inverter power to 4000W seems to be working as a temporary workaround.

If it is not too much trouble, would you mind taking a look at my VRM history (installation ID 02160482c318) before I open a support case with Victron? The last temperature warning was on 6 Jan at 12:17. It was pushing 200W to the AC input and 4200W to the output (4400W total) at the time, and then reduced power by 700W to 3700W when it overheated. Ambient temperature was 32C. The pattern is the same with all the other temperature warnings.


okay! So something did change in recent months, an extra step got added into the derating curve. Cool.

Sounds to me like it is working correctly, it just shouldn’t unsettle the user by raising a warning.

Can’t seem to find it on VRM? I can see it is a Cerbo from the id. But I’m not sure I would be able to see anything there anyway. I would just go ahead and raise it with HQ. Possibly they know about it already.

1 Like

Not Victron, but on my Goodwe it doesn’t have any fans - just a honking big heatsink that covers the whole back of the inverter. It’s designed to be silent and passive, but I found that during high ambient periods the internal temp sensor of the inverter would read up to 65 degC. I don’t like power electronics running that hot, so I simply attached two 120mm 12V silent PC fans under the fins of the heatsink, blowing up through the bottom, which runs permanently. Now the internals of the inverter never go above 46 degC. It’s debatable if it makes a difference, but it makes me sleep better at night.