Victron minimum SOC issue after power being reinstated

The other evening after loadshedding our power came back on for a little while and then something popped at the substation in our area so we had no mains power until the following day at around 11.

My Victron shuts down when the batteries drop to 10% which they did in this instance and then as soon as my solar panels started generating power in the morning got the batteries up to 11% at which point the Victron started feeding my DB and started powering everything again but, my issue is this…

Usually after an outage this long my initial load is around 1000W and in winter when my solar power starts kicking in it takes a couple of hours before I can start producing at least 1000W so that I can sustain this draw so I’d for example be drawing 1000W and producing say 500W so then what typically happens is it runs everything for a couple of minutes and then shuts down because it drops to 10% and the SOC protection kicks in, a few minutes later they get back up to 11% and the whole cycle is repeated, this causes a bit of havoc with some of my IOT devices and is probably not particularly good for my appliances.

Anyone know if there is a way to prevent it from doing this and either have it come back online when it gets to say 15% or to a point where its producing more power than the demand?

I had to eventually isolate the inverter from the DB board to build up some charge and also wait until my solar generation was at around 1500W but was away at the time and proves quite challenging to get the domestic to do this over the phone.

You can take a look at the “shut-down on SOC” if you don’t have it already. There is a restart value there which I think should do what you’re looking for.


I’m assuming in your case the battery is sending the DCL=0 at 10% to stop discharge causing the shutdown, but allows charge once it’s at 11% again, but if you have the restart set to a higher percentage that might do it.

1 Like

Thanks @fredhen the SOC low restart seems to be exactly what I’m needing.

I take it that is done through the VeConfigure app? I worked with it once about 3 years ago when we originally setup the system, does it connect via USB cable?

Limit the inverters max watts?

I do that using what goes into the batts.

Like if 100w goes in, then the inverter is set to 100w … 5.6kw, the inverter is set to 4kw.

EDIT: I trick it when it is fully charged, so at 97% I set it to Keep Charged, then the setting is ignored.

You can make use of Remote VEConfigure:

I would just double check the Details section to make sure that it is possible for your system as it requires a specific VE.Bus (Inverter) and GX firmware amongst other things:

  • VE.Bus firmware versions 416 and 417 can not be configured remotely

  • Remote configuring firmware version 418 or later requires the GX device to run v2.10 or later

If possible on your system then you should be able to download the configuration from the VRM portal, open it up in VEConfigure, make the required change, save it and upload it again following the steps in the Step by step procedure section.

The posts on lowering the cutoff volts do not solve this scenario.

The batt will just be drawn lower, maybe till the BMS cuts out, potentially causing more challenges.

I don’t see how that would help though if there is no mains power and my SOC is at cut off?

Unless I’m not understanding correctly but I’d sort of be in the same position then where for example my solar power is only 500w, demand is 800w and if I’m then limiting my power to 500w I’m still going to have the issue of devices not being powered or being powered off intermittently and battery charge level dropping. I do think the only option is to only bring the inverter back online when its at say 15% and when chances are I’m producing more power from solar than demand or its back at 15% because mains power is back on.

Well yes, that’s my current situation and what I’m trying to get resolved.

Great thanks, I keep the firmware on my GX up to date, currently on version 3 so should be ok. I’ll give this a go as I do believe it is the best way forward and will resolve my issues.

Right, then you have:

  1. Too little battery capacity.
  2. Loads at the time too high.

If your loads are “fixed”, that is what you have to have, then you have to add more batteries whilst making sure you have enough panels to recharge the additional battery capacity.

this isn’t a common occurrence and only ever happens when the Eskom sub station goes offline so wouldn’t warrant me adding more capacity for something that may happen once a year, I’d rather change the configuration of the system to work around this issue. I’ve only ever been offline in these instances early morning when the batteries eventually run out and solar production hasn’t yet started so its not a train smash but as per my original post I’m trying to protect appliances and also not have IOT devices factory reset.

My critical loads are relatively low and not possible for me to lower them even more, its things like my IP camera’s, alarm, networking gear, fridges, intercom, lights, home automation etc… and usually runs at a pretty modest 500w average.

Hear you. Been there myself.

Lowering the min cutoff is definitely an option, but is it the actual solution?

You lower it, while later you again hit that cutoff … what then?

Handle the cause, not the result.

I’m not wanting to lower the cutoff SOC, like you say I’ll hit this new lower cutoff anyway and be in the same position. I’m wanting the inverter to only come back online at 15% (5% higher than my SOC) as this will then most likely mean I’ve started producing more power than I’m consuming and is safe to bring my devices back online, I believe the solution fredhen proposed as per below is what will work for me.


The idea is to incrase the SoC restart value. Cutoff at 10%, but when the BMS allows discharge at 11% don’t restart the inverter until 15% or 20% to first build a bit of a buffer in the batteries from PV so that by the time the inverter starts up again there should be enough PV + batteries available to carry on.

1 Like

Correct :+1:

Is it not working then?

I haven’t yet made the change, still need to but I’m pretty sure it will work.

1 Like

Go for it!

I would set it to 30% to accommodate the above. Rather wait a little longer and have a good buffer. You can then decrease this for summer or as you learn to manage the loads.

1 Like

That’s actually a great idea, would make sense to adjust this to cater for Cape Winters and summers.

The process with VEconfigure is a little cumbersome, would be great if this option was available under Minimum SOC via the web interface or device manager or even better with modbus, I’d imagine quite a few users would want to change this value.

Anyway, I’ve changed this value now and will report back in a year or so when it happens again :smiley:

Thanks for all the input.