Venus OS Large on Pi3

Hi All

I have tried to move from a pretty standard Pi3 setup (Buster) to Venus OS Large. I am keen to have Node Red running as I used to have on the old setup - I run a battery SOC set of LED’s for various SOC levels and Grid Indicator. All just LED’s off the GPIO pins.

I see now that the Venus OS doesn’t allow all the GPIO pins to be used - have read a bit about this and am keen to hear the solution if any. Are there “open” GPIO pins I can use to drive 5 LED’s…?

Note… My incredible depth of technical knowledge above - be gentle :wink:

Well, you can use any GPIO that isn’t in use. Two of them are used as RX/TX for a serial console (and you cannot really get past it, u-boot doesn’t boot without a serial console… unless you recompile it without that). Other than that, the most obvious pin is already mapped as a relay (just because it was conveniently close to the edge of the header), and you can add other pins too. Just define it in /etc/venus/gpio_list.

Generally you should skip anything that is used by other stuff, like SPI, I2C, or the aforementioned serial pins. In addition to GPIO21 on pin 40 (already mapped), there are at least 15 more you can use without a problem. Venus automatically creates a link for it in /dev/gpio.

1 Like

Thanks @plonkster

Now to mission on to the /etc/venus/gpio_list … :thinking:

You need to SSH into the “Venus” using Terminal from any Linux OS or CMD from a windows machine. Then you need to use this command : vi /etc/venus/gpio_list , once you are in the file you should use your cursor to reach the next open line, press i (to be able to inset some text) and add the pins, when your done press Escape then : then wq and enter to save the changes.

After that, i am not sure how to intergrade node red. Help?

It’s already integrated in the large image. You just need to enable it in the Remote Console. Cant’ be easier.

1 Like

Thanks Louis, did not know this.

Well, for the uninitiated, probably rather use nano instead of vi. Vi itself is an editor that takes time to learn.

I’ve been using vi since 1997… mostly because I still haven’t figured how to quit out of the thing.


I also don’t know how to quit :smiley:
Luckely my fingers have some memory built in and know that if I am in trouble with Vi to click :wq!

Personally the first think I do on any new linux system is to install Nano. What an upgrade!

ctrl + S - Save
ctrl + x - Exit

1 Like

Hah. On a new system that is one of the first things I move to the side. Usually by the first time I commit something to git, and nano pops up… aaargh… I forgot to update-alternatives --config editor

The old “I don’t know how to quit” thing is a joke, because that’s one of the very first things people run into when they start using it. I have the muscle memory thing too, to the extent that I sometimes quit something when I was still busy with it… grrr.

Another thing I do very often is to hit ctrl+Z instead. That backgrounds the editor and hands you a shell prompt back (if you quickly need to do something in the shell). Then simply type fg again and the editor comes back to life, and you can continue right where you were, complete with the undo history and all buffers intact.

That activates scroll-lock, which is another thing that confuses the heck out of newcomers. scroll-lock hangs up the terminal. You have to hit ctrl+Q to get out again…