Using ESS to switch between Mains and Inverter

How do I switch back to grid charger in the early hours of the morning?

I have tried switching back to “Charger only” using a timer in node red using “Optimized - with battery life” and “Optimized - without…” but the inverter only switches off when the timer kicks in…
I have set a scheduled charge for 7 hours with SoC of 90% in the early evening and it stays on Mains for a while but as soon as the Multi,s output is stable for a bit it then changes to Inverter mode and “self consumption”.

What am I missing here?

Or would it rather be better to control the discharge settings as per TTT cronjob thread?

GVC, I’m not 100% sure what you are trying to do.

Way I use Scheduled Charge is not for charging the batteries, but stopping the system from using batts for X period of time for example from 3pm, for 7 hours with SoC of 15% will stop the system to use any batteries, and it will not use Eskom toe recharge, due to low SOC, from 3pm - 10pm.

This is set on the Venus.

If I want to change Keep Charged to Optimized and back, that I would do in a Cronjob on the Venus.

1 Like

On the vebus service, you can set /Mode to 1 (Charger only). Set it back to 3 (On) to discharge again.

/Mode is the switch position, or at least the software representation of it (of course the physical switch is not going to move like an old Technics Hi-Fi of the 80s :slight_smile: ).

1 Like

Haha, I loved those hi-fis where the volume knob turned when you pressed the remote!

If you want to physically click the switch, try this one: :wink:

The new ones of course all have rotary encoders. No more servo control. But that also yields a riddle every now and then. Like my car radio, which for reasons that wasn’t immediately obvious tops out at 63.

Why 63? Of course my software-developer brain immediately identified that as the largest number that can be represented by 6 bits… but I could not fathom why someone would want to represent volume as a 6-bit number. The answer turned out to be way more obvious that I imagined: The analog component responsible for the signal level is a digital potentiometer… of which the most common variants have 64 discrete values, from 0 to 63.


Hi Plonkster
I used the vebus service to change over, but the inverter switches off when it changes over to mode 1 and or swtching to mode 3

Thanks TTT, this can also work for me, however after only 2 hours into the scheduled charge it changes back to inveter self consumption mode.
Could this be this because my “Stop on Soc” is set too high at 90%?

I think so yes … lead acid is ideal at 80% SOC.
Lithiums about wot, 40%.
… assuming no LS planned.

1 Like

Thanks TTT. It is already working as you described it.
This will work perfectly. :+1:

1 Like

[quote=“plonkster, post:6, topic:197”]
The new ones of course all have rotary encoders. No more servo control. [/quote]

What especially irks me (my cheap LG DVD player does this) is when the rotary encoder gets confused between steps and can’t figure out whether it is going up or down. So then it just jumps between 2 or 3 values :confused:

Just turn faster :smiley:

My very expensive Razer BlackWindow Elite mechanical keyboard does this on its volume dial (guess you can use it for other stuff also because it can be programmed). The turning faster method of @Louisvdw seems to work, but I am more than a little frustrated at such poor quality control. It is just not enough of an issue for me to go through the trouble of sending it back.

Oops, I spoke too soon. An hour after my post the Muli changed to inverter while it was still supposed to stay in scheduled charge mode…
I read online that I had to update my Multi firmware to see if that sorts the problem out. I have just updated to the latest firmware

My SD card is full after a month, so I have just purchased a 64gb. I tried an external USB disk first but it is messing around with the VRM portal.

Why is it full?

What exactly are you trying to do?

I presume it is because I have logging enabled on VRM online portal. Is it not supposed to be enabled? Besides I only had an 8gb SD card when I set up the RPI ESS system.

I am trying to set up my system to suite my requirements…Run on grid to 23:00 or so and then enable battery to take over till morning, but I just cant seem to get the setting right. The Scheduled charging that I tried to run till 23:00 changes to Inverter mode at about 19:00 and if I set a timer to remote switch the multi to charge only the bloody thing switches off.

Thanks guys, all sorted now. It would appear that it needed the firmware upgrade.

I don’t have an SD card installed, if Venus loses internet connection, it will stored the data locally until it is connected to the internet again, and then send all the data. Otherwise, I’m not aware of any SD card required or data stored locally.

If you keep on having issues, drop me a PM and we see what we can do.

1 Like

@plonkster, I am taking a long shot here…is there a way to install Venus os on Ubuntu 20.04.1 running on a rpi 3, like the victronconnect AppImage?

In theory yes. If you used an ARM emulator (such as qemu) and you manage to figure out the exact config to make u-boot boot it, and assuming you don’t need to recompile the kernel too… yes you can make it work.

1 Like