US 3000C pylon tech

I have oldish inverter . Had a single US3000c pylon tech battery running with it. Alll worked well. Added a second US 3000c . Whole system does not work . Only run light flashes on both batteries. Any ideas. Popped BMS?

Are you sure you followed the setup process correctly for the two batteries? I.e. correct the power, put the communication cables between them, turn them on and pressing the button only on the master? Something like that.

What happens if you just go back to the old battery?
Did you set the new battery as the master?
Have you tried using just the new battery alone?

I have heard from others that sometimes the firmware needs to be updated for them to work but personally never had any issues with mixing us3000c bought over time and even up5000 added recently.

1 Like

Yeah , was working for a week or so. Changed masters around as well. Now also change inverter and result is same

Any other suggestions. Swopped batteries around . Still nothing doing. Both batteries have their run lights flashing - does that mean there is still some charge?

What are you based


Please pop me a dm with your number. Will try and pop in tomorrow afternoon to assist. I need to take a drive.