TP-Link AV600 Powerline set up assistance please

I tried drawing a sketch on Word but suck at it and would thus rather try to explain the issue I’m having.

I’m trying to get rid of LAN cables and have purchased the TP-Link AV 600 wifi kit with an extra extender.

I have 3 routers all in the different rooms and all connected to each other with long LAN cables but with only two wifi networks set up.

So lets call them routers A, B & C

Our fiber line enters the house and goes to router A. No wifi network was set up from this router, but B & C that is fed from it, provide their own wifi under different names.

So router A, I connected to the AV600 adaptor and plugged it into a wall socket.

The 1st extender that was successfully paired with the adaptor, is plugged into a wall socket at router B in a different room and connected to it thereby eliminating one long LAN cable. The internet reaches this router B as router B supplies internet signal onwards to our TV and router C also via long LAN cables.

The 2nd extender however, I cannot get working. I have tried pairing it with the adaptor and believe I’ve possibly succeeded, although I had some issues in the beginning. The sequences of pairing leds did not do as they were supposed to but when I swop them around, the 2nd extender works where the 1st one is plugged in.

But when I plug in a PC for example in anyone of the 2 ethernet ports on either of the two extenders, it connects but tells me there is no internet access. That’s why I believe it is not a circuitry issue and also because I have plugged the 2nd extender into various different sockets that run on the same line.

I have not yet attempted to make use of the extender’s wifi function as it is not really required, but working ethernet ports is what I’m after.

Surely it cant be necessary to play around with or setup IP addresses and what have you to make this work? The instruction manual has no troubleshooting section, and their online support has not responded in more than 48 hours yet. I also couldn’t find any info on the internet on this issue yet.

Does anyone have any experience with these units? I am really useless with stuff like this, I couldn’t even set up my own wifi networks. How do I get those ethernet ports to work? There is 2 on an extender.

Please help a technologically challenged noob out.

I have a couple of Powerline devices that I bought ~8 years ago, but it’s the other way around for me. I only used them where it’s not possible to pull a LAN cable or while I was still planning on how to get the LAN cable where it’s needed. I still prefer a LAN cable above anything else for the stable connection that it provides.

I don’t know about the devices that you get today, but I know that the ones that I have are extremely sensitive / temperamental and surge protector plugs, multiplugs etc. would generally cause them to stop working / not connect to each other. I had one that I used until a couple of weeks ago and it would stop connecting when my batteries are charging or if the washing machine is being used and I generally couldn’t get higher speed that ~5Mbps from it.

I also saw this. On some plugs it simply does not want to make a connection. I think it’s either got to do with what else is running off that same circuit breaker or the circuit breaker itself or something. In my case I had my main plug in the living room by the router, but I was only able to get them to work with the plugs in the garage and not the plugs in the kitchen or bedrooms.

I am going to take a guess and say if you take the 1st one that works and plug it in where you would like to have the 2nd one it also won’t connect there? That would pretty much confirm that it’s just a case of the Powerline devices not being able to talk to each other over those circuits.

To be honest I think it is still best and more stable to have a LAN cable between access points / routers and I will always try and neatly pull a cable and only use the Powerline devices as a last resort, but that’s based off my experience with them from ~8 years ago like I mentioned.

One thing I do is to first pair it close to the first unit – preferably in the same room. That way you can eliminate any issues with the pairing process itself and just confirm that it works. Then move it to the intended location later.

The lights on the unit to say it is connected to the network should be a good indicator, but I think the TP-Link comes with an app too?

I did notice on mine that while the light initially lights up, it might disconnect after a while. So give it time too.

And yeah, what was said about surge plugs are definitely true, and also distance and also how many circuit breakers it seem to cross.

1 Like

I also would suggest you do the set up and pairing in the same room and then move it further. That way you know it works when it is close by, so if it does not work in the other location it is either interference or perhaps a fault in the network cable (swop cables to check that)

Some other useful tip but that is not related to your question is this. Make all the routers use the same SID and set them to use the same channel as well. This way you have one network you need to join devices to and the strongest signal will always be connected too. Works very well. Your routers just need different Fixed IPs, which you can use to connect to each one in turn if you need to. Also, make sure the router that gives out the DHCP IPs is also set as the gateway on all the other routers.

There are no multiplugs or any surge arrestor type plugs in this mix. Just socket straight to socket.

The 1st extender definitely connects to the adaptor via wall socket, because it gives internet signal to the 2nd router. But why would only one ethernet port on it work? I plug a pc straight into the remaining second port, but nothing. Now how could this be possible?

In other words, the unit gives signal to a 2nd router via one port, but not through the other.

The pairing it would seem is not the problem. Its the ethernet ports that are not working. Well, the 2nd one on the 1st extender at least.

All lights come on. The app I have down loaded but I have no idea what to do with it. No idea what to set, where and how.

Distance is probably not even 40 meters. They talk about operation up to 300m

I don’t even know what half of this means (SID, DHCP etc), let alone setting it up like that. I really cant do stuff like this. All I know is that everything connected to the internet has an IP address, that’s it.

I had a friend set this up for me and the wifi works quite well. Would always like to improve, but that’ll take months once het gets to visit again - lives 450km away.

SSID = the name of the wifi network.
DHCP = the service that hands out IP addresses.

Sometimes bringing in additional devices results in more than one dhcp server, which means they effectively fight to hand out IP addresses.

What louisvdw is saying is that

  • only your router should be handing out IP addresses and thus have it’s DHCP server/service enabled
  • the Powerline Wifi extender should not have DHCP enabled, but the second Wifi network that it broadcasts (SSID) should be the same as the main one.
1 Like

Thanks, I understand what you’re saying, but its above my paygrade to accomplish this.

So either I wait for my friend to come in visit in a few months time, or I return the devices as there is absolutely no support whatsoever from TP-Link. I’ve left 4 messages already.

Dynamic Host Configuration Protocol.

Before that we had BOOTP. We used to boot computers without hard disks back in the day, using only dhcp/bootp and tftp (trivial ftp, which is a dumbed down ftp service by which a computer can fetch its OS from a networked machine).

Even now you can boot a Raspberry Pi (if you replace the bootloader with u-boot) from a dhcp/tftp combo, and mount the file system from another machine… :slight_smile:

Even more Greek, lol!

Anyway thanks. I will try to get someone here that understands all these terms and how to work with them.

Just a warning, there is no after sale service from these mofos whatsoever, should anyone be interested in purchasing their products. I will never again.

But then again I’m the only idiot here, you guys work and deal with this stuff on a daily basis, its not as if you need these assholes, save for warranty claims.

I wouldn’t necessarily expect better support from other providers. I’ve used many TP-Link products over the years, and while they are your typical IT product from the general China/Taiwan area of the world, the UI isn’t riddled with spelling mistakes, the manual isn’t in Chinglish, and the stuff actually works… if you know the basics of networking :slight_smile:

I will easily buy TP-Link again.

And therein lies the rub. Guys like me find themselves now out of pocket in excess of R2k, with no assistance whatsoever in getting the product to work. I mean there is just no one at the other end of the line. That kinda sucks.

Talk to your Local IT guy …

Or the neighbour’s teenage son…

1 Like

… or daughter … :laughing:
Ladies are as sharp with IT stuff … just saying.

So try this. Unplug the cable that you know is working in the 1st port and plug it into the 2nd port.
If it works in the 2nd port it’s most likely the cable that is causing an problem, so you can try another cable.
If it does not work in the 2nd port then I think you’ve got a faulty 2nd network port, so you should return it as faulty.

If you unplug the 1st one that is working and plug the 2nd one in at the same plug, does the 2nd one work?
If it does then there’s most likely nothing wrong with the unit, but it’s a case of the Powerline connection that cannot work where you are trying to plug it in at the 2nd location due to electrical interference, crossing DB’s, crossing breakers etc. and there’s unfortunately nothing that you can do about it.
If it does not work when plugged into the 1st one’s plug, then you’ve either got an issue with the pairing, so reset it and try again (keeping the 1st one disconnected) or you may have a faulty unit.

I was very impressed with Asus’s support. When my ADSL line had issues a few years, they were a great help in looking for the issue, suggesting changes to settings, etc. In the end it was a problem with the line, but their settings help stabilise the connection (although at a much lower speed)

Just some feed back here. I had a friend over that is substantially clued up when it comes to these things and we went through the entire setup process again.

His verdict turns out to be that the 2nd extender is faulty. Cant get it to pair with the adaptor no matter what we do. So I’m returning it tomorrow and awaiting a replacement unit.

Adaptor with the 1st extender works flawlessly.

Will update again when I have it and if this turned out to be the problem.

1 Like

Glad to hear – that’s better than your house’s power lines being “not compatible”.