SOC Oscillation Victron

Hi All

I have an EasySolar system 48/5000/70 with a 150/100 MPPT.

About 3kW soar panels

I run a schedule charge between 16H00 an 06H00

I run ESS in Optimize without battery life

Min SOC is set to 50%

When the SOC hits 50% the loads get powered from the grid and the full solar goes to the battery until 53%.

Then the system revers to load being powered from the battery and solar.

This leads to a continuous oscillation between 50% and 53%

What I would like to happen is that at 50% the load gets powered by the grid and solar and the batteries get nothing until such time as the load is less than solar only.

Then only the excess solar goes to the battery

Can this be done?

Not immediately sure if there is a clever way of doing it with the ESS settings, but doing it with Node Red should be easy enough. Set Max Inverter Power to equal PV Output when batteries hit 50% with ESS min SoC set to 45% rather.

However, the situation you are describing sounds like it shouldn’t be the norm, or how have an undersized PV setup for your house’s needs? Either way, does the behaviour really bother you that much?

Yes. The PV is smaller than the max demand but much bigger than the base load

The only concern I have is that the sum of all the oscillations will become full cycles and affect battery life?


Based on this graph, panels are working “flat-out” for the time of day, yet batt is oscillating between 50-53%

Question is: What was the AC during this time, ±12pm-4pm?

Because of this:

The max average demand will cause that oscillating behavior.

Yeah, that’s a problem, when you don’t have enough PV to power the loads.

Doing the reverse, somehow limiting power use from the DC side so that this does not happen, has a different problem with some batteries: SOC drift. The battery cannot properly measure low amounts of power (usually below about 1A), so balancing the power in a way that uses the PV while only slowly charging/discharging the battery causes severe SOC drift on some batteries.

So pick a solution, and some people will complain.

Best solution for now, if this is a common problem, would be to limit your inverter power on the ESS menu to make it smoother.

Isn’t there a new setting to not export battery power to non-essentials? That might be a good first stab.

*Edit: Ah yes, self-consumption from battery set only to critical loads might solve the problem. It sounds like the PV was specced for critical loads, not total loads.

1 Like

Adding to that, maybe this option under Self Consumption from Battery:
Just run Critical loads only off the batts until more panels can be added.

1 Like

Very hot at the moment. Aircons running. Guess I can just go to keep batteries full and the problem will go away.

If the aircons are non-essential, the above mentioned setting change will also work and still allow battery usage at night for the criticals. It will therefore utilise the batteries better as well as not degrade them over time as I understand a fully charged lithium cell would do (my understanding is that they are happiest if at around 50% SoC).