Quattro with Relay Assistant behavior

@TheTerribleTriplet Here we go. I am going to explain this in simple terms even though I know your are technically minded but for the benefit of other users that might not be.

Variables Used:
Time Delay of 120s (this is an arbitrary number, can be anything).
Critical Loads on ACOut1
Heavy Loads on ACOut2
Grid on ACIn2 (Quattro)
Firmware: Latest, 481 but have been tested on several older versions with same results
*Note: This solution used to work 2 years ago. Also, the explanation below is part of a bigger solution but this is the part that is failing.

Background: When using a Multi out the box with loads connected to both ACOut1 and ACOut2 there is a default delay that returns power to ACOut2 after a grid restore, I think it’s 60s or even 120s. Anyway, it works fine.

Come the Relay Assistant with ACOut2 Relay as the controlled component. As per the Vicron manual, using the Relay Assistant will cancel ALL default operations for said relay, in this case the ACOut2 relay. This means you have to program the relay to exactly mimic the default behavior + whatever you want out of the assistant.

The requirement is for ACOut2 Relay to disengage when the grid fails and then reengage 120s after the grid has restored. Yes, I know this is default behavior but I could have chosen 600s which is longer than default.

The relay assistant looks like this:
When ACIn2 is not available for 0s then disengage ACOut2 relay. This works perfectly!!

The flip side is like this:
When ACIn2 is available for 120s, engage ACOut2 relay.

This should work right? It used to work and I see no reason why it shouldn’t work, right? Wrong!! It doesn’t work as expected.

The observed behavior for the first assistant is spot-on correct, ACOut2 relay disengages immediately when the grid power is lost.
When the grid power returns ACOut2 relay engages between 6s-8s from ACIn2 being available. Where did my ‘available for 120s’ go? And that is the problem.

Here are the consequences of this behavior: ACOut2 relay engages even before my Quattro has sync’d with the grid meaning it still supplies power from the batteries. I have noted Overload warnings on my system in very special cases where the geyser was cold enough to enable the element, the pool was in it’s running cycle and someone started the microwave to do something so you get the picture. It could trip the unit in a worst case scenario. Luckily that has only happened once and the rest were warnings.

Here is the strange part. When you configure a Multi and update Assistants, the unit reboots once the configuration is uploaded. On that initial reboot the ACOut2 relay takes… you guessed it, EXACTLY 120s to enage as per the programming. If I now flip the breaker to toggle the grid power then 6s to 8s later ACOut2 relay engages. Strange but true.

I am perfectly willing to accept that I am a Tjop and made a programming error but for something that used to work, and now doesn’t WITHOUT changing the programming, seems to be the mystery.

Phew!! A bit long winded I know but have a think about this one and let me know. Please also no workarounds, this is a basic feature of the unit that should work as advertised and will be used in a bigger scheme of assistants so a single workaround for this will not work for other that require a timer and a relay.

PS. Controlling any other relay EG. K1 etc. behaves the same so the issue is the timer if you ask me.


That sounds to me like a software/firmware bug that probably crept in via other enhancements over time seeing as it worked and then stopped.

If you have weirdness with the assistant (which is like a small code extension that runs on that 8-bit MCU inside the multi), there is only one guy who can fix that. The guy who writes the assistants. You need to get in touch with support.

@plonkster I’ve tried that. Via dealer, via reseller, via local V* support, via the Community and even via ‘the face of Victron’ in a PM and they all basically ignored it.

Let me rather say, no one tried to really understand the issue so no one tried to fix it. Guy at least told me upfront that he cannot really assist but would pass it on to the big M* and that is where it died yet again. No one contacted me, even though two other dealers/reseller got the same results on the bench using brand new kit, yet no luck.

No you know why I am saying when you are stuck, you are stuck. It feels like an end-user raising an issue is the lowest priority and that the Support people pick & choose the low hanging fruit over the difficult ones. As you said, it’s expensive support that needs to look at this but, maybe it’s just me, I would be curious if someone finds a bug in my code, even if I have to go to the garage after hours and simulate it to satisfy my own curiosity… but that’s me.

Sorry, I went off the handle there a bit. I am actually very calm about this and accepted this as-is.

Seems to me all reasonably expected actions have been taken i.e. dealer, reseller, local support, Community, and even Victron direct, with no success yet.

Maybe someone can ask for the right person to get involved … I mean, we have the resources here and a successful conclusion of any Victron matter is simply enforcing the “we care” culture Victron has built.

What you are describing is a regression.

The answer would be to go back to the version that worked. Unless there is a reason why you must be on a particular firmware version, or if that version is very very old. Asking for the firmware files of an older version is a common support request and should be much faster.

I wish I had a better answer for you. The issue here is that this is a problem affecting a really small group of people (you), and you need the attention of one of the busiest developers in the company. I’d say… keep at it, sometimes that helps :slight_smile:

@plonkster The firmware regression testing is also something that can’t be done back to the original one from two years ago. As you know, VE Config updates automatically so you always have a somewhat recent version on your laptop if you accept the upgrades. The challenge was, and I tested this and also couldn’t find a workaround, to load the old firmware and the old VE Config but then the Assistant feature was disabled due to components that were too old. If you upgrade one item then they all follow the sortoff same upgrade path to keep people from using old assistants with newer firmware etc. It’s a good way to keep things current but is bad for end-user regression testing when hunting a bug.

Don’t worry, I’ve given up. I really lost sleep the last round I tried to get things just ‘looked’ at (as is evident from all the people I had to go through etc.) and don’t want to go through all that hassles again.

Don’t give up. Schedule a monthly reminder. Keep at it. From what I have gleaned, the Victron development culture is very focused on the current crop of targeted features and only showstoppers will interrupt that focus. Keep at it, it will make its way up the TODO list and it will get looked at.

1 Like

@warwickchapman Today we switched on my RS450/100 and I showed the installer the relay behavior and he couldn’t believe it. He assured me that he will test it on his bench and make sure it gets some attention from the right people. It’s a bold statement but I am going to hold him to it - I said I will transfer the final payment once it’s working (I’m sneaky… but I told him upfront about this)

Eish. He might wait a bit for that.

Nothing like a bit of pressure… :laughing: But I am not overly unreasonable.

1 Like

So just a bit of feedback. No progress from the Installer side - I think they either struggle or just busy (it got quiet on that front).

On the otherhand, I tried to implement Charge Control connecting the K2 relay to the AUX1 in and the same timer issue is prevalant there. The Charge Control loop works perfectly but the K2 relay timer exhibits the same symptoms - it does not honor my 1200s programmed. Seems like the problem is bigger than just the ACOut Relay but again, I think the timer process is universal and just a new instance created per Assistant or when required.

PS. This is just for information. No action required unless someone wants to independently confirm my findings.