Pylontech Address Allocation Error

Hi all

Please can you assist me with the following issue I am having?

This issue has now been persisting for a few days and I have not found any solution as yet :frowning:

  1. I have a Victron Quattro 8000/48V system since 2019.

  2. It is connected to a CCGX unit and 2 MPPTs.

  3. It is also connected to 7 batteries - 5 (US3000) and 2 (US300C)

  4. The unit is configured to work with the Battery BMS and follows the settings and setup as articulated in the Pylontech manuals and Victron website.

Victron & Pylontech UP2500, US2000, US3000, US2000C, US3000C, US5000, US5000B, US5000C, Pelio-L, UP5000, Phantom-S, Force-L1 & L2 [Victron Energy]

  1. Over the years I have kept the unit updated with Victron’s OTA firmware updates.

  2. Last week I decided to add another newer Pylontech US3000C unit to the system.

  3. As per the usual protocol I charged the unit to 100% SoC.

  4. Once done I connected it to the existing stack of 7 batteries as the master - set dip switch 1 for unit to 1 and canceled the prior master moving this down to 0. (the batteries are physically stacked as 4 and 4 on brackets - however they are according to the manual only in 1 master in the group)

  5. The newest battery was connected to the CCGX and all the link cables run from this unit onwards.

  6. The system worked fine for a few days - then however it started to throw an internal error - a red light on the master unit.

  7. CCGX states - voltage low alarm and internal error

  8. I tried again to charge all units independently and balance the system - no luck

I realised that when you power up the batteries with the SW switch it only powers the master and the next slave and stops and goes no further.

If I change the master battery - this doesn’t resolve the issue either - I have tried multiple battery configurations as master now.

Since my email last Wednesday, I managed to get hold of BatteryView (3.0.23) on Saturday and I can see the master battery is showing an Address Allocation Error.

I have attached 8 screenshots of the batteries from the master unit onwards.

I have also taken 2 pictures of the setup so you can see that.

you will see the address numbers go from the master being 1 to 2 (first slave) to the rest being either numbered 16 or 8

I have no idea how to get the pylontechs communicating with the victron again :frowning:

I have also looked at the following topic - Pylontech Firmware Updates (We Take No Responsibility For Any Firmware Posted Here, Choose Correct Firmware For Your Battery) - #234 by TryingToPylontech

How do I fix this?

(see attached photos from BatteryView - showing the error)

Thx in advance

Uploading: US3000A_Slave_Battery_4.PNG…
Uploading: US3000A_Slave_Battery_5.PNG…

Uploading: US3000C_Slave_Battery_2.PNG…
Uploading: US3000C_Slave_Battery_3.PNG…

As far as I know you should not set the DIP switches. Each master… ahem… primary can manage 7 secondaries. Eight in a group. Slaves have address automatically assigned. Master of each group must have the dip switch set for the group. Only one group… set it to zero.

When you have more than 8, you need an LV-Hub. And then each group has its address set on the master.

Try switching it all off, clearing the DIP switch on the master. And restarting.

Thanks Plonkster

The dip switches was set on the primary more for the Victron CAN baud rate. I however did attempt your suggestion. It didn’t work.

However I ended up entering the serial numbers of the various batteries via battery view software and that seemed to solve the issue. Strange that a missing serial number would cause that issues. But I’m guessing the bms is using that info somewhere.

Please switch all the dipswitches’ off. With pylontech you do not do addressing with the dipswitches’.

I do not see a Can cable that goes to the GX. Can you please add one.

1 Like

Thanks. Did do that. Seems to be working :grinning:

1 Like