MPPT Behaviour during Scheduled Charging

Yesterday was a funny day in Bellville. Cloudy one moment, the next clear, the next raining.

As I didn’t want to drain my batteries unnecessarily, I switched my ESS to scheduled charging (with low stop on SoC to basically just charge with excess PV but not discharge) during the high load times in my house (geysers). Then I got busy with stuff around the house.

The sun came out fully around 12:30 and I was quite excited to see how the PV was running my 3kW geyser when the panels are nice and cold.

I saw the batteries sitting on 100%, but the MPPTs chilling on 1200W (I expected 3200W at least, given the time of day and the icy wind). Demand in house was about 3300W (geyser plus the usual). This confused me as there was no shade on the panels.

I turned off scheduled charging and wham, MPPTs ramped up to 3600W (covering the loads after conversion losses).

Is this some type of safety on the DC side to prevent the batteries from being overcharged when the AC load drops off? If so, I’ll just factor in that when deciding on my scheduled charging slots.

The MPPTs work on voltage. If the battery reaches the target voltage, they start to throttle.

When scheduled charging is on, it does a few things. First it enables overvoltage feed-in, so that the solar chargers charge a little higher than the Multi expects, and then the Multi feeds in whatever is higher than expected. But… it limits this amount to the loads you have (to avoid feed-in).

But in scheduled charging it also limits the power to the loads to 93% of what the PV brings in (because that is pretty much the peak efficiency of the inverter) to avoid discharging the battery.

Some interaction between the two could perhaps cause the problem you describe, though it is not quite clear how that could happen. 93% of incoming PV should cause the battery to slowly discharge, causing the voltage to drop, and the MPPTs to ramp up.

But there is another issue, one that we frequently see, but which has nothing to do with scheduled charging. It will also happen if you set the ESS mode to “Keep batteries charged”. That is when the MPPT and the Multi has slightly different measurements of the voltage. This is due to calibration differences, but also because there is a voltage drop over the cable from the MPPT to the battery (in other words, the voltage is higher at the MPPT). Since the offset that is used in this case is a mere 0.4V, all you need is a combined calibration and voltage drop of 0.4V, and then the system stops working properly.

So to test it… well you can either download your data from VRM and check the voltages there (which is what I do when I need to look into this), or you can just go there with a multimeter and measure it.

Thanks! I’ll do some digging on the VRM data and see if I can piece together the reason.

Have noticed a change from when I used lead-acid batteries to where I’m now using lithium, as the Venus/ESS software was updated over time, as the awesome team at Victron does.

What Plonkster says is what I have seen and I do not dispute that at all.

But what I’m suspecting, a change took place and now, when the batts are getting ‘fullish’, the MPPT throttles back “forgetting” to power for the grid-tied house :laughing:

Maybe there is something that can be done?

The MPPT knows nothing about the loads. It simply aims for the target voltage. It’s the job of the Multi to feed the loads with the “overvoltage”. That’s why when debugging this you have to look at the voltage each device sees.

Then a debugging session must be arranged, or I need to be told in baby steps what to check for … at a time and place of the MPPT’s choosing to behave as described

It seems to stay in the “mode” for about ±1 hour IF one spots it in time.

Dropping the Min SOC value during that time, not that it makes any difference as the system just sits there not using any batteries, seems to “trigger” the system to get the MPPT to ramp up the production again so that the Multi can feed the house with solar … my workaround IF I see it.

Always think carefully about what happens. In the cases where I debugged this with you, your MinSOC was higher than the current SOC of the battery. In this case, the Multi will not take any power from the battery. It will wait until the SOC rises above minsoc.

If you then drop the MinSoC so that it is lower than the current SOC of the battery… well then of course it is going to start using power from the battery, and then of course the MPPTs will see the drop in voltage and ramp up. That’s common sense.

I see this in many installs, at least it’s almost stereo-typical South African by now. Small battery packs (relatively speaking) running at high levels of charge (cause load shedding). And the voltage and SOC does not necessarily correlate, as everyone knows by now. The SOC drops below MinSOC and the Multi stops using DC power… but the battery is still full enough to reach absorption voltage without a lot of current… and voila. No loads are powered, and the MPPT is limiting on voltage.

This is less of a problem on LFP, because usually an LFP battery only reaches its target voltage somewhere between 95% and 100%.

Note: the one you looked at the other day, forget about that one. It is “fixed”.

System Settings:
Min SOC on ESS is set to 90% - ready for evening use - I drop it manually to 50% when Schedule charging takes over.
Battery SOC is hovering at 95%+ accepting say 100w charging.
House loads are ±1500w
MPPT is set to 100amp charging.
DVCC is set to 60amps, inverter set to 70amps.

Array potential at the time is ±3kw.

Two Scenarios:

  1. System draw only 100w to charge the 100w the batts still take, ignoring the 1500w grid loads
  2. System draws 0w from the MPPT.

In both cases, if I drop the Min SOC then to say 85%, it triggers the system to draw the expected ±1500w + batts of 100w = 1600w.

I then set it back to 90% … we all live happily ever after.

The worst thing is, smack bam in the middle of peak production, the batts are full and the geyser need heating, the MPPT is told to stop producing, geyser is heated by Eskom.

How do I avert this from happening, as before, with lead acids kept always above 80%, even Keep Charged for weeks, this never happenend.

You need to check this carefully. Once it hits minSOC (90%) it needs to recharge to 93% before self-consumption is re-enabled. If you lower the minsoc to 85% during this time, it re-activates self-consumption. If you then raise it again to 90%, it remains in self-consumption.

It is a simple state machine. At minsoc it stops inverting DC into AC. At minsoc+3% it starts again. If you lower minsoc and raise it again, you force the state machine into a new state.

This is precisely the sort of thing I see a lot of the time. A battery at 90% SOC (especially if it is lead acid) does not accept a lot of charge current. The MPPT has no choice but to limit on the voltage. And the state machine will not flop back into self-consumption state until it reaches 93%. It is unfortunate, but that is what happens.

Less of a problem with Lithium because they accept charge current more readily, and the voltage tends to only spike up right at the end.

It is much better to switch to Keep Batteries Charged at this point. It won’t actually use power from Eskom (because the batteries don’t accept much charge current, and the MPPTs can provide all that). And the upside is that in Keep Batteries Charged, the inverter component inside the Multi is not switched off…

1 Like

Ok, Keep Charged. I will try that tomorrow manually.
At say 10h30 I will set the system to Keep Charged, irrespective of SOC, and see if Eskom does steps in or not, if not, then that is a winner. If it is a bad solar day, so what if Eskom steps in. I just want to see the full array power between 11am-3pm … as then the “big” loads are on.

So a question in case the above does not work as I hope it will.
Is there a way that I can override the system and force it to stay in self-consumption, using the current Cronjob?

Yes. Lower the minsoc :slight_smile:

1 Like