MPii 3KVA with Pylontech

So brand new install… Multiplus ii 3kva GX, Pylontech US3000C…

So like magic plugged it all in… battery detected, all working… except…

Battery Monitor [512] - High voltage alarm: Alarm

These are coming in constantly. The battery parameters look fine (they are according to pylontech spec).

Speaking from personal non-pylontech experiences, having had those alarms, in my case it always is a cell that is out of whack. I just leave the system on and let the BMS sort it out, setting the Min SOC to like 80%.

So I should actually cut the AC input to let it cycle? I doubt I’m going to discharge past 90% SoC with the 2hr load shedding windows…

I’m NO expert at all, least of all on Pylontech, but letting the system do it’s thing is the best option, AC connected, unless someone else has a better idea.

BMS must sort the cells out.

The reason why I said 80% is to drain the cells a wee bit so that the warning goes away, the BMS still balancing as fast as it can.

If LS returns, I see it is lifted, then just drop some of your critical loads when the SOC nears 20% of some such.

Is your DVCC setting turned on? Check the voltage of your Pylontech batteries in the Venus menu. This should be around 52.4V when at 100% (or 52.7/8V when at “Keep Batteries Charged”).

DVCC is off… I’m assuming it should be on…

Yes. It should be. Otherwise the GX will not listen to the batteries (or something like that).

I believe that your installer should have ensured that the Multi’s charge parameters itself should conform to those of the batteries (for if the GX falls away) as well as the charge parameters on any MPPTs you might have. But while the GX is up and running, DVCC should enable it to control those.

Pylontech makes a 15 cell battery, so if the default is to try and charge it like a 16 cell, it will not like it at all. I wish I understood the limitation of a 15 cell battery before I bought it. I dislike my DC voltage being so “low”. A 16 cell battery would have been much better for the 90A MPPTs I bought.

I shall go reprimand myself severely and refuse to recommend me as an installer to anyone else!

all the errors cleared now:-)

2 Likes

Are you making use of the ESS assistant on the Multi?

The best would be to follow the Victron page:
https://www.victronenergy.com/live/battery_compatibility:pylontech_phantom

I would first start there and make sure that the Multi & GX is configured according to the Victron documentation.

They do also mention high voltage:

Note: The “Limit managed battery charge voltage” feature should be left OFF, unless you are experiencing “High Voltage” or “Internal Error” alarms. These alarms can indicate that there is an internal cell imbalance in the battery. It may be useful in this situation to enable this feature, and then adjust the voltage limit down so that the batteries are able to balance charge without reaching over voltage internally. This imbalance is at a cell level, so might not be reflected as a high overall battery voltage if measured with a Multimeter. This can then be turned off once the battery has balanced itself properly.

And a second part under the FAQ (I see they are recommending to keep the batteries charged until the error goes away in order for the BMS to do it’s thing (top balance):

High voltage’ warning or alarm shown on battery status

The ‘high voltage’ warning or alarm is not unusual on new batteries that are not yet balanced. To help the batteries balance quickly, keep the batteries fully charged until the errors go away. In an ESS system, set it to ‘keep batteries charged’, in an off-grid system the fastest way is to either charge / balance the battery before installation, or to fully charge with a generator if not enough solar is available to keep the batteries fully charged.

If you are unable to maintain the target voltage to balance the batteries without the ‘high voltage’ alarm occurring, you may need to enable and set the “Limit managed battery charge voltage” setting in the DVCC menu of the GX device. Reduce this voltage as necessary until the alarm stops. After sufficient time to balance the batteries, try increasing this value until it can be disabled again for normal operation.

If it is not possible to raise the voltage over time, and eventually disable this manual override:

1: If you have 2 or more batteries in your system, you can try shutting down the system once it is as close to fully charged as possible, and then physically connecting the batteries in smaller groups (or even individually) so that balancing can occur on each individual battery without it being masked by the others connected in parallel. It may help you to see the indicator lights on the battery (if available on that model) to find which battery might be out of balance with the others.

2: Contact your Pylontech dealer for further assistance (they can provide additional software to see individual cell level data), or assist with other potential solutions.

So I would say configure it according to the Victron docs. If you still have the alarm then I would say that you can then look in detail at the FAQ about high voltage and then you will most likely have to enable “Limit managed battery charge voltage” and drop the “Maximum charge voltage” until you no longer get the alarm and give the battery some time to balance while having it set to “Keep batteries charged”. After a while you can then increase the value and if you don’t get alarms when you’re back at 52.4V you can disable the option again.

Edit:
Should have just posted the link first which has a nice table including DVCC:

Venus Settings → System Setup Parameter Value
DVCC ON
Shared Voltage Sense OFF
Shared Temperature Sense OFF

But still, have a look at the documentation and configure it like that and you should be good to go.

I’ll still recommend that you fix it in the Multi’s config files and in the settings of your MPPTs. This is just a failsafe should the GX get a hick up.

Also, don’t be too hard on yourself! At least now you know this part! If that was your only issue I’m sure you are a better installer than most. :smiley:

1 Like

Thanks everyone for the input… we are now alarm free.

Glad to heat you got it sorted. The Pylontech battery should technically configure automatically. There is even an issue in the bug tracker for it. But for now, you still manually have to turn on DVCC.

With DVCC off, the charge voltage from the battery is used only by the solar chargers (not the Multi). There was some legacy setup that required it to be that way. No need to fret about that now that it is fixed.

Overriding the charge voltage is a very new feature in the latest versions. That is there so that you can lower the charge voltage in case the battery has an imbalance. Batteries often have a cell imbalance when brand new. The system should use 52.4V for your battery, which should be perfect.

@plonkster I see my CVL is 53.2V for my PylonTechs with DVCC enabled. Has this changed subsequently?

image

That is correct, but the GX says thank you and ignores it and sets it to 52.4V far as I understand. If you set it to Keep Batteries Charged, then it will set it to 52.8V. So my understanding is that the 53.2V is what the batteries’ BMS tells the CAN bus, but Victron decided that it knows better. :stuck_out_tongue:

I wish I had 4 US3000s…

Is this for real … cause that makes a lot of sense if it does. See, when my batts get to 100% SOC, being DIY, it is a very cool idea to drop the voltages, as on a SOC above 95% is where cells get “too happy” if they are not perfectly in balance.

@plonkster will have to confirm if I’m speaking the truth or not. Above my paygrade (which is 0, incidently). :sweat_smile:

You are 100% correct, thanks.

I checked my home assistant graph for the voltage read directly from MODBUS and the maximum voltage was indeed 52.45V, rounded up to 52.5V on the graph.

image

53.2V is too close to the maximum of 54V. And as we discussed elsewhere, that high up Lithium Cells becomes very prone to spiking up and with Pylontech that causes the entire thing to switch off. So some people who will remain anonymous spoke to more people on the other side who will also remain anonymous, and figured out the lowest possible voltage that still allows the balancer to do its job, and so that voltage was initially replaced with a 52V target. The trouble with 52V is that it only gets to 99% SoC most days, and it does slow down the balancer, so it was raised by 0.4V, which was empirically determined to be a better target (and also got you to 100% more reliably).

Do the math yourself. 53.2V over 15 cells is 3.55V per cell. That’s just way too high.

In future this may in fact be raised to a consistent 52.8V. And yes, in some ESS modes it does sometimes go up to 52.8V already :slight_smile:

Edit: Especially now that there is a way to override the setting, a higher default is easier to justify.

Correct, see the code here: dbus-systemcalc-py/dvcc.py at master · victronenergy/dbus-systemcalc-py · GitHub