Home Automation Fail

So there I was, earlier this evening at around 19:00, sitting in my TV room with the door closed (to reduce the noise from the rest of the house). Laptop open in front of me. Fancy shirt on top, (shorts on the bottom), shaved and hair nicely made up, Samson USB Studio Mic in front of me, giving a presentation to ~100 Americans.

Camera on, lights on, all going well.

10 mins into the presentation the lights go off. Stupid automation that I set up to turn off the lights after 20 mins of no motion. :disappointed:

Of course, wearing shorts I can’t get up to go and jump in front of the motion sensor, so I apologise, get out my phone and start searching for Home Assistant (I don’t want to open up HA in a browser since I’m sharing my screen). A colleague on the call asks if it is loadshedding but my other colleague knows me and makes a joke about wonky home automation systems.

In the process of finding my phone I bump the mic, which causes it to disconnect and reconnect (the Mini-USB port is well worn) which causes the teleconference software to pop up a modal dialog asking if I want to use the new hardware (which is pretty much the same mic it used 10 seconds ago). In the process of sorting it out I somehow lose the popup window behind Powerpoint and browsers and the Teams session I have open on the side, which means I can’t unmute myself again since I have to click “Yes” or “No” first, but can’t find the window.

Luckily we had a video we were planning on showing, so my colleague switched over to that while the South African try to sort out their sound in the dark by fumbling with their phone.



Haha! Well, at least you didn’t get up.

Maybe have a “party toggle” or something that bypasses the “switch off after” script?

I think that is why they say it is better to talk with your hands as well.

Always though it had to do with body language, but now I see it is so the lights keep on. :smiley:

In the beginning I had a lot of these “problems”.
Two ways of handling the on motion switch. Have a “soft switch” that blocks the off command unless it is switched on.
The other thing that I do is also connect the same soft switch to the hard wall switch so if the Auto on is ON and you switch the wall switch off then the soft switch will also be off. This gets reset once a day so I you are going to sit down for a while just toggle the wall switch.
As per usual , many ways to skin a cat!

Yeah, this is not a bad idea!! Because I do get similar issues with the patio light and back yard lights when we have people over (And the kids are playing in the garden etc.)

EDIT: That being said, I could have disabled the automation before the session. Problem was here that I forgot about it completely.

Do you use momentary switches (i.e. push buttons)? So that you can do a double-tap?

Actually not a ba idea either - I have Shelly’s in those switches, so replacing the switch with a momentary button (I like the “Dimmer” buttons that CBI sell since you can just swap out the switch) and adding a double-tap option which disables the auto-off could work…

Then there is this … you came off light @ebendl :laughing:

The CBI momentary switches work well, I also swap out the cover from the old switch to get rid of the writing on the switch. I have automations that run on single, double click and “on hold”. Its nice being able to turn on the lamps in the room from my wall switches.

1 Like