Grid import here seems higher than needed?

Set to Optimized without battery life. While charging up the battery everything appears normal in terms of utilizing solar input but once the battery is charged the Multiplus seems to use grid and minimal solar despite the load from appliances. Panels could easily supply 5000w at the time the image was captured (It wasn’t cloudy). It’s a daily occurrence since returning to Optimized without battery life after using Keep battery charged mostly during winter. Any ideas why solar is largely ignored?

Once >98% SOC, set to Keep Charged, instead of Optimized. Solved the issue nicely. Better way to do it.

@plonkster can explain more, but it is a caveat (my word) with Optimized and high/100% SOC.

Simple enough. The algorithm is very deterministic. If the state of charge is less than the minimum you specified, the inverter component inside the Multi (the part that takes DC energy and turns it into AC energy) is switched off completely. That is because, below the minimum soc, you don’t want to waste any energy, so it goes to a lower power mode by switching that part off.

In practice, when you set your minsoc to 100% in optimisied mode, your battery gets to 100% and we start feeding in energy… then it drops to 99.9% and it stops feeding in energy. Repeat…

On top of that, a battery that is 99.9% charged doesn’t accept much charge current, so your MPPTs are also throttled.

The effect is a system where the MPPTs are ramped down because the batteries are too full, but no energy is used because the battery isn’t full enough.

The answer is: Don’t do this. The “Keep Batteries Charged” mode does the right thing. Use that.

(This problem is WAY worse with lead acid batteries too. With Lead Acid, if you set your minsoc to 85% or higher… prepare to have issues you don’t like. Because Lead Acid stops accepting charge current from 85% upwards… but as in the previous example, no energy is used because we’re below minsoc).

1 Like

Thanks @plonkster It makes mere sense the more times I read your post :wink:

@Mako Are you running a Cerbo GX? (or any GX) and ESS Assistant on the Multi?

I have mine setup the same as you and don’t have this issue.

In my case, I ran into the “caveat”. The reason is I upped the SOC to get 100% SOC for the evening round of “taketh none from Eskom their watts”.

The secondary reason is that with the weather, one can be stuck at 30% (your example) SOC for days on end, necessitating SOC vigil and LS schedules with weather reports for 8 a.m. slots.

So I up the SOC in 10% jumps during the day … hence I hit the “caveat” like in “face planting” on ice.

Cerbo GX. Seems the same as yours but significant draw from grid like this during the day when the battery is charged. Keep battery charged as @plonkster suggests does maximize the solar draw but I think it’s going to charge from Eskom at night. Currently set to Keep Batteries Charged.
2023-10-17 13_48_08

Oh hang on… your minsoc is set to 20%. This is a completely different issue.

So let’s start with the basics. The MPPT doesn’t care about the battery’s state of charge. It doesn’t even know what the state of charge is. It cares only about the voltage. If the battery voltage has reached the voltage the MPPT is aiming for, it will stop charging. It has to, otherwise bad things happen.

Conversely, the Multi will simply power the loads from the battery. As the battery starts discharging, the voltage drops a little, the MPPT will then wake up and start charging again, and the result is that the MPPTs and the loads sort of ends up in balance.

The battery voltage is the controlling parameter though.

It seems in your case, the Multi is not powering the loads. Completely different issue. I cannot see in that picture why it won’t do it. PM me the site id, and I’ll see if I can get around to it (though, you should be asking your installer this question :slight_smile: ).

1 Like

Installer is a big company that advertises huge projects om Facebook. Client is the widow of a very good friend. Installer is useless, you wont believe the state of the install. I have sorted out what I could and keep an eye on it for her. I’ll send you the site ID directly and would appreciate a look over when you find time.

If I am not mistaken if you activate BatteryLife it does this automatically in 5% intervals, probably not as frequently as you do it manually though.

From 6. Controlling depth of discharge
“During periods of poor weather when solar energy is reduced, BatteryLife will dynamically raise the Low SoC limit which has been set. This has the effect of making less power available for consumption. It raises this level by 5% each day until the energy which the system draws from the batteries during a 24hr period matches the energy being replaced. The aim is for the battery to operate at or near 100% SoC.”

Yes, I sometimes do that on bad weather weeks.

Daily I use NodeRED to do it for me.

@plonkster Has identified the Limit Inverter Power setting as the possible culprit in my case. I have disabled it and will watch today as solar ramps up,


@plonkster nailed it. I disabled Limit inverter power (no idea when it was enabled) and all back to normal this morning with Optimized without battery life.



The grid setpoint of 150W seems on the high side. I have mine on 20W. Unless there’s a specific reason, you are buying quite a bit more energy than you need to.

I started at 50 watts and bumped it up bit by bit until the smart meter stopped tripping. I would like it lower too as there is excess solar and a large battery. Maybe I should go down in smaller increments until it trips again. At 100 watts it would run for a few days then trip so even that is too low. The trips cause stress at that site as the single resident living alone doesn’t know what to do.

I understand. However, if the system is registered, don’t they install a meter/provide a code so that the meter don’t trip on feedback?

I’m not an expert but the way I understand it… some meters are tolerant of short period low wattage feedback spikes and can be adjusted if troublesome. Others detect feedback and trip, then reset and sometimes if it’s too often it doesn’t reset and you have to call the electricity department to reset your meter. Bi-directional meters are available in Cape Town for feedback. The installation above is not set up for feedback.

As long as you are registered grid-tied, you shouldn’t have this issue. For example, for my house they installed a pre-paid meter that doesn’t trip. I’m not sure of all the details of the different types of meters, but as I understand it is that the meter will simply bill you both ways when set up correctly.

Yup. Mine does that. If you register for SSEG, they either install a prepaid meter (if you don’t have one), or they replace the one you have, and they install one that doesn’t trip on reverse (but does bill you).

If you want to avoid that, you need to spend the 12k-15k or whatever it is these days for the bi-directional meter. Hopefully they get it down to a more affordable <5k soon.

I have a bidirectional meter that was a lot cheaper than that. (well maybe not a lot, but it’s one of the affordable automatic metering devices. Probably cheaper than most prepaid meters.) The point is that that fee is unnecessary nonsense fees.