Goodwe, eco mode, and no/low grid

This may be applicable to Goodwes, maybe more general. I don’t know. I share it here as a lesson learned and that somebody may not have to learn in future. And maybe because somebody who really understands the Goodwe ES inverters may offer corrections & further enlightenment.

Saturday morning we had an early morning outage (not load shedding). Round about 9AM. It was a clear, sunny day, but look…


If you’re not familiar with SEMS portal, the blue line is PV being drawn from the panels, green line is SOC, orange line is load.

PV drops just as the outage begins. You can’t see the blue line because it is on the zero axis, behind other lines.

Now I have for some time run my Goodwe in “Eco” mode. This allows you to set time slots during which the battery will discharge or charge. I have it set for one charge slot - 15:00 to 16:00. This so that on overcast days my battery gets an afternoon charge and I am good for the evening.

So the first thing I checked was the front panel of the Goodwe. This has an LED to show if either of the PV strings is active. It was burning a solid blue - so it could “see” both strings. I checked the Goodwe app - it showed 250 odd volts on each string, but no current.

OK… this should have led me away from the path that I was about to follow but I

  1. Turned both the PV breakers off (LED went out).
  2. Checked the fuses with a multimeter - they are good.
  3. Replaced the fuses, checking they were located correctly.
  4. Turned the breakers both on.

Well maybe it’s going to kick start something. But it didn’t. The app still reported 250 odd volts and no current. The LED still burned., No PV was being drawn.

At this point I start googling for after hours PV troubleshooters. There don’t see to be any. So now what?

Had I played with any settings lately? No. This is against my religion. I don’t touch that stuff. Also the Freedom Won BMS will override any changes I make on the battery side (spoil sports!).

So I changed the mode from “eco” to “off grid” because, really, I am off grid.

Bingo! It starts drawing PV and charging the batteries again.

In for a penny, in for a pound. I now changed it back to “general” mode. In this mode it uses PV, battery, grid in that order. Now when the grid comes back the inverter will know and can use it if it needs to.

But now I started thinking back to another recent incident. Thursday just gone.

So now the PV is up and down and the battery is actually discharging more than it is charging. I checked the Goodwe app, and the incoming voltage is low. Alternating between mid 180s and low 200s. The Goodwe, with safety code set to “South Africa”, disconnects from the grid at around 195V. It reconnects at about 200. The change I made here was to switch it to the “50Hz default” safety code. Set like this, the Goodwe doesn’t care what’s coming in as long as it’s above 170 and it’s at 50Hz. You can see the problem going away.

So I should have put two and two together here: When the inverter is in eco mode, when the time is not within a charge slot, and when it doesn’t accept or get any grid input, it doesn’t take any PV, no matter how much is available.

Later in the day, with voltage back but still low, I changed safety code to “South Africa” and inverter mode to “eco”. Straight away the PV drops to zero (inverter not getting any grid power).

I then put the inverter back into “general” mode and turned off the main breaker for the property. The drawing of PV was unaffected.

This was still strange to me, because I had the inverter stuck in eco mode with that single 15:00 to 16:00 charge slot for over a year. But looking back through the history on SEMS I found smoking guns. Like this one

Conclusion: If the following conditions are in place

  1. Inverter in eco mode
  2. The time of day is outside of a charge time as per eco mode
  3. No grid coming into inverter (for whatever reason)

Then the inverter will not draw any PV. Possibly until a charge cycle/time slot is entered.

So I am leaving my Goodwe inverter in general mode, unless I have to charge from grid.

I had left it stuck in eco mode because you can change modes remotely, it’s a security blanket, and because I was too lazy to change the mode every day.

Yeah ECO mode really is for managing the battery to/from grid.

If you get paid to push to the grid, it starts making sense. Where it really make sense is in the european countries, where the rate you pay and get changes all the time. So the idea is to charge from grid when its cheap and discharge to grid when its expensive and you then get more.

In SA that is not the case, so you generally, want to keep the inverter in general mode and only use eco charge when you need it, like no sun and batteries almost depleted or you know a loadshedding slot is on the way and again not enough sun etc.

TL;DR, eco mode bad in SA and good in Europe.


What @tinuva said.

Some older firmware versions shuts down the PV when in backup mode, regardless operational mode. It seems they did not really test with the South-African use-case in mind.

If you want to manage your inverter remotely, the best is a Homeassistant instance and VPN.

Yes. I can’t believe I haven’t noticed this before. Though, as I said, there are some smoking guns to be found in history in SEMS.

What I was told, by Goodwe, is that backup mode is intended to replicate an old-fashioned UPS. Hence the slow charge rate.

Hi I also own a Goodwe and “discoved” eco mode in a discussion on Powerforum.
My System Goodwe ES 4.6kW inverter, 6,2kW solar panels, 7kW Pylontech batteries (now 14kW). Able to feed back into grid.
My observations, will try to back up with images from cef’s utility for the Goodwe (If I can figure out how to insert images)

  • Goodwe’s use of eco mode is poorly documented or probably more accurate “not documented” the Goodwe help desk also not able to help.
  • The management interface seems unstable, never sure if changes are actually applied
  • I’ve not expereinced the PV “shut down” shown by Bobster
  • I am able to make changes remotely via SEMS (as installer) but see point above
  • In Eco mode you can charge the battery from the grid, and at quite a rate >2kWh.
  • I realised my inverter was clipping solar production in summer at 4.7kW. By delaying charging the battery to say 11h00 via eco mode I was able to increase solar production to 6,3kW+ as the inverter seems to treat charging the battery via another path. In theory I could increase solar production by 0.5kW for 2 to 3 hours a day, provided the batteries are discharged.
  • Trying the above during load shedding produces a block like pattern with charging increasing to say 4kW and falling to 2.6kW, this pattern repeats itself, not able to fix this.
  • The inverter switched back to general mode but was still using some of the settings of eco mode.
  • Eco mode discharge settings are in line with on grid DOD. I tried to increase battery dicharge but it stops when in reaches the on grid DOD.

OK. So it’s nothing to do with Eco mode. Now I am thinking expensive thoughts.

Today I have this

Safety code is 50Hz default.
Inverter is in general mode.
Grid voltage is 204V
Inverter has disconnected from grid and is outputting 231V
The inverter can “see” both strings but isn’t pulling any power from them.
Battery is discharging.
The only thing I see that might be deemed unusual is that grid frequency is 49.9Hz - but the inverter has accepted that before.

Weather isn’t great in my part of Johannesburg, but there is sunlight, yet the PV input is shown as a nice round zero.

Possibly interesting detail: The SolarGo app no longer displays a firmware version. That field is just blank.

Does your inverter log any other errors? (Other than the VAC error) Can see that with PV master, unsure if SolarGo also shows them.

While searching for the Solarwifi my SolarGo app displays a version V5.0.6 in the top right hand corner. Not shure if this is the latest version. Access for the past month has been poor.

I’m going to try generate a report and see what fields are available to me in SEMS. I’ve checked the logs with SolarGo and PVMaster and they are the same in both apps.

But PVMaster shows a firmware version number - which is reassuring.

I think you should log a ticket with goodwe support.

My inverter had a similar but different issue. Some times, after loadshedding finished, I would have 0 solar when the grid returned, and the whole house would use only grid power. The inverter however did log an “isolation” error fault. Received a very long set of instructions back, to the point where I was like…err let me get in a solar installer (my initial installer passed away some years after my install).

Without an installer’s help, I was able to point the issue to a specific PV string. The installer came and was able to find there is in fact a grounding issue on the string, strongly hinted at by Goodwe support.

Anyways they are busy fixing that right now, so I will know in tonight and the next few days if I still have this issue.

The point I am trying to make is, sometimes Goodwe support can be really good and I am very happy with the response, even though they can’t fix it, I had a good set of instructions to provide the current solar installer I found, who btw doesn’t know Goodwe but he is an electrician so can definitely confirm or not from the Goodwe provided instructions.

1 Like

So it happened again this morning. Forewarned is forearmed and I was looking out for it.

About 7:00 I started getting solar coming in, but not a lot obviously.

Inverter was in general mode with safety code set to South Africa. And it’s been operating happily in that configuration all week.

8:00 load shedding started.

8:00 the inverter stops drawing from the panels, even though it is connected to both strings, and can see 250V plus on each string.

I change the mode from general to off-grid and this kick starts something and the system starts drawing PV again.

I change the mode from off-grid back to general and it carries on happily using PV.

I tell the household they can use the kettle.

The installer is no help. After all this time I don’t expect free service, but it would be nice to get a response. Their Goodwe expert has moved to some other venture and is now not available to me :frowning:

I am going to log a call with Goodwe support desk and see what happens.

I’m also going to start looking around for somebody who will trouble shoot system they didn’t install (this is out of the installer’s warranty, so there is no problem there) and who, hopefully, knows the Goodwe ES inverters.

So there is a remedy available to me, that I can use whilst I’m in the house. But
a) In 4 years of having this system I have not had this problem nor had to resort to this changing of modes just to kick the system up the jacksie.
b) What if I’m not here? Other folks won’t even notice. The battery will keep on discharging. Sure we have about 5kWh available at this time of day, but with the low grid voltages and with trips after load shedding 3-days running, the battery could just keep on discharging until it gives up.

So the remedy available to me shouldnt’t be necessary and isn’t much use to anybody else.

You could technically automate that work-around with home-assistant, however I am not sure if that is something you would want to do.

I agree with you, first prize is Goodwe support log in to the inverter to see what is logged, even better if they can be on while the issue happen. I have seen a post on another forum I will not mention, where goodwe found an issue by looking at the inverter as it happened. In that case, the inverter lost one of the chargers, so the batteries couldn’t charge at full speed, but only at half capacity.

The goodwe support definitely can help a lot here I think, there is no one else that is more of an expert than them.

That said, on github I have read people mention sometimes you need to get past 1st/2nd line support and get to the escalated line, then you get the real experts to sort out issues.

The spirit is willing, but the flesh wants to put it’s feet up and watch Inspector Morse reruns. Also nothing seems to be quite reliable in terms of getting the PV side working again. Or there is some variable I am not spotting.

Previously I have had good support from Goodwe. But they seem reorganised now, and there are lots more layers you must go through to get hold of somebody who really knows stuff. It was a long slog getting access to the “configure” button on SEMS, and it still doesn’t do anything that I want it to (it does do things that I don’t want).

I wonder if there is a lot of local expertise. With Victron or Sunsynk or even Axperts there seems to be a lot of people with good knowledge of those systems and who can trouble shoot. I spoke to my installers last week. I didn’t expect anything for free after all this time, but we had load shedding, and despite it being a nice sunny day I was getting nothing from PV. They had one guy who knew Goodwe inverters well, he’s gone, and now they have no expertise at all.

I should play the Lotto until I win, then install a Sunsynk.

Pal had a Goodwe, had it sent in to many times, no luck, the moment it goes back up, the error returns.

Told him to contact GoodWE HO in Europe.

He got support locally after GoodWE Europe got onto GoodWE SA’s case, who in turn got onto the local distributor’s case.

Learned that move when I got fed up and contacted Logitek/Nokia Ireland for a No 7 key on a Logitek Kbd and separate instance, a Nokia warranty repair, when local SA offices gave me the cold shoulder. Logitek kbd was shipped for free from Ireland and the Nokia phone was repaired under warranty by a local M$ repair center.

PS. Not that it has any relation … both the above cases I took a chance on a Sat afternoon, with “asking is free, as is the no” attitude, to email them. Saturday afternoons work for me. :slight_smile:

Let’s revisit this.

On … err… the other forum there is a post from somebody with a Goodwe ES who is complaining that batteries don’t charge when the grid is down. Coincidentally this morning I had load shedding at 8:00. It’s a clear, sunny morning, but throughout the load shed the Goodwe would demand load + about 45W from the panels, and send the 45ish W to the battery.

So at 8:30 this morning with the loads in the house low I was pulling 400 W from PV. The last two days at the same time, with the same loads, I was pulling > 2kW.

If the load increased, the draw from PV increased, by enough to send that little trickle of charge to the batteries.

Which is unhelpful because 8 in the morning is when my battery is at it’s lowest SOC (having got us through the night and having heated the water).

The moment the grid came back, the PV starts running flat out again.

Firmware version is 2121D.

Anybody got any ideas?

OK… there is one thing that kicks things back into life and that is putting the inverter into off-grid mode. But I shouldn’t have to do that, and I’m worried about forgetting to change it back, and the non-essential circuits will work in that mode when the grid comes back, but won’t get any assistance from PV.

Wait, so your inverter isn’t going into off-grid mode automatically when there is loadshedding? Something sounds broken. I would open a ticket to let goodwe investigate this when it happens again.

Do this also happen if you trip the mainswitch from eskom?

Ummmm… It is certainly reacting to the loss of grid, but not as I expect it to. It’s doing just enough so that it doesn’t deplete the battery any further. If I switch modes using SolarGo then it draws as much as it can for a few seconds then goes back into non-depletion mode. If I push the loads up then it continues to draw load + a few.

I don’t see a change of mode in SolarGo. Are you saying that it should show as in off-grid mode in SolarGo when the grid drops?

That’s a good question. The battery is charged now, so I can’t do this test until tomorrow morning.

Question: Surely load shedding and the municipal breaker being tripped look like the same thing to the inverter? Why might behaviour differ?