Error on Remote VE.Configure of Large System

On a large system I commissioned recently with 9 x 15kVA Quattros, I cannot do remote VE.Configure. When trying to download configuration, I get:

I see there is something in Gitmemory about this being an issue > 6 units but it seems solved: Remote VE Configure error 61 on large systems 6+ Multi's - venus

You don’t say if this is 1ph or 3ph?

Hey Phil, 9 x 15kVA in 3-phase configuration.

Hardware configuration: Three phase system, three units per phase

Well, you shouldn’t be falling foul of the above limitation with that then.
Can you re-upload and re-apply the existing configuration as it was uploaded sans any changes?

Nope. Site is 4.5 hours drive away and I don’t have a file. Simply assumed I would be able to download, modify and upload.

Normally, I upload, save a copy, modify another copy of the upload, then download.
Isn’t there a working configuration on it already?

Once or twice it has failed to upload, but the original file stays on it. Then I’ve tried again and it’s been accepted.

Yes, the system has a working configuration loaded directly over MK3 when commissioning but not saved to file.

However, battery charge parameters need to be adjusted and I assumed I would be able to do that remotely as with all other 100+ sites.

My VRM is down else I’d point you to the specific menu, but you can definitely upload the existing configuration through VRM.
The option is in there somewhere.
That’s how I change settings, first upload, save, then change a setting then download again.
Even if I originally applied the original file locally via MK3.
I’ve done it plenty, from the otherside of the planet.

what GX device are you using there and firmware?

Yes. But to upload, you need to download first to open and modify for upload.

Cerbo 2.66

Quattro 481

have you tried to roll back a version of on the cerbo?

Mine is a Venus, not a Cerbo, but I wouldn’t imagine it’s different ( it’s a VRM feature).
You can definitely get the file first.
Definitely, definitely, 100%.
I am not saying this is the case, I can’t remember, but maybe ‘upload’ and ‘download’ are ambiguous. I do quite a bit of this kind of work, sometimes these commands are switched by the manufacturer depending on what they consider is the reference device.

Phil, that error reflected in the OP is him trying to download the config file from the 9 x Quattro 15kVA and it is failing. I don’t think it is a question of how to do it but rather why it is failing if this issue was supposedly solved in an update.

Yes, but the file that is on it already is obviously acceptable, if you upload and are unable to download the exact file again, it means the download process is broken.
If you take a brand new file there can be many discrepancies that make the the new file unacceptable.
Narrow down the variables.
When you have an issue, finding the solution is a process of elimination.

You’re going to have to ask the people who know. In this case that is not me :slight_smile:

There is a tool called mk2vsc on Venus-OS that does the uploading and downloading of things (yes, you can use it over ssh if you know what you are doing, it is very very useful).

In this case it is exiting with a return state of 61, which means what the message says there. Either something is wrong, or there is a bug in mk2vsc. Either way, need to probably take this to community. I doubt repeated attempts will make it act differently.

I click Download:


I did at Error Message: 'Incompatible VEBus configuration' Error: mk2vsc-61 - Victron Community but no reply.

1 Like

Is that site on the latest Venus version? I ask because I notice the error message in the screenshot is old. Some consistency changes were made, one which was to more consistently spell it VE.Bus :slight_smile:

In Venus 2.66 it should say:

Incompatible VE.Bus system configuration. Writing system configuration failed.

1 Like

Ok, That gives you something to work with, now you know it has nothing to do with the new file you want to upload. There is a communication bug.
I don’t know how to fix that, but my next step would be to get onto Victron support.