Does a Second VE.Bus Device on a GX get BMS Controlled?

If there is a Quattro 48/15k connected to Cerbo GX Ve.Bus and a MultiPlus-II 48/10k connected via MK3 to USB on the Cerbo, are both VE.Bus devices BMS Controlled?

In this case we have a generator onto the Multi and Grid onto the Quattro so that grid and gen can be used at the same time to support the system.

We need to be sure that the MultiPlus-II will listen to BMS Parameters, especially CVL.

I’m pretty sure it will. The BMS sets the value in the GX’s dbus and all the other devices listen to that.
I have 3 BMS devices. The one I select as the Battery Monitor’s value is used by both my Multiplus and both MPPTs.

Ahem. This is something that bugs me at the moment, and will soon change.

So here is what happens at present. The device with the lowest “device instance” is controlled by the BMS, and the other one is left alone. The built-in VE.Bus connection always has as lower Device Instance than a USB connected mk3, so the result is that it always controls the one on the built-in port.

That sounds simple enough… but…

If you turn off the “main” unit, then the first one plugged in via USB becomes the lowest, and it starts controlling that one. Which is probably not what you want.

And then, if you turn the “main” unit back on again, it stops controlling the external unit, which then goes into passhtru after 5 minutes because it has lost its BMS.

Hence… this will change soon. In future it will only control the device on the built-in port.

For devices without a built-in port, such as the Raspberry Pi and the Maxi-GX, the old rules remain in place.


So we did a battery change today and the MultiPlus was stuck in passthru. I eventually updated firmware to 500 to try “reset” it and get it out of Passthru, which seemed to work. Tried a battery redetect. Tried to reboot GX.

As an aside, what I noticed after the updated to 500 - may be related or not - is that the grid loss detection on the MK3 connected device (which we previously had to manually clear once) keep re-appearing. We thus disabled grid-loss altogether on the GX and replace it with an Active Input Disconnected alarm (hope this is the right one to use).