Adding another us3000c PylonTech battery to a LuxPower hybrid inverter

I recently had a hybrid solar system installed with a LuxPower hybrid inverter and two us3000c Pylontech batteries. The system worked perfectly and decided to purchase and add another us3000c Pylontech battery of exactly the same spec.

So I started by switching off the Isolator switch and also the switch on the inverter and disconnecting everything. I then put the new battery in the top of the stack to make it the Master. Connected the batteries in Parallel but left the power cables from the inverter and data cable unconnected.

So I had previously waited for the current two batteries to be fully charged. I then turned the batteries on in order from the Master to the last battery. The batteries have an LED light which has ‘RUN’ underneath and a set of six light with an triangle underneath to indicate state of charge. All six state of charge lights where full lit on the current batteries.

I then pressed the SW Run button on the new Master battery. This new battery had two LED lights lit on the state of charge. On the two current batteries each LED light on the RUN started to flash and on the new battery the RUN Led light was fully lit. So seems like it had started the balancing successfully.

I left it running over night. In the morning all the lights were out except the RUN led light on each battery including the new master battery was flashing, alternating between each of three batteries.

I then turned the batteries back off, reconnected everything. The positive power inverter cable to the Master’s other positive connection and the negative inverter to the last battery on the negative connection. I then connected the data cable from the inverter to the rs485. (The battery also had an option for CAN, which online videos seem to use. But since the inverter was originally connected to the rs485 port by the installers I added it back to the same one).

After switching everything on the battery LED lights remain unlit and the inverter asks ‘Add a battery?’. So my question is should I try to enter the settings on the inverter again or maybe try pressing the SW Run button on the master again with everything including the inverter connected. Or should I try the CAN connection instead of the rs485? I didn’t want to try anything else until I got some expert advice.

thanks in advance

Here are two pictures of the current system before I added the third battery

Here is a picture if the new battery added as a Master at the top, with the Positive and Negative power cables and data cable disconnected from the inverter. And the Inverter and Isolator switch turned off.

Have you tried toggling the RS485 baud rate setting? It is the ADD switch block, position 1.

This setting is only read when the battery is powered on, so what I’ve seen before is that these get misconfigured by a feather duster or other cleaning implement and then the system continues running fine for months until the next time the battery is power-cycled and then the inverter stops talking to the batteries and everyone is baffled.

These are the steps I would follow:

  1. Hold the SW switch on the master for 0.5s
  2. Toggle the power switches off, starting from the master battery
  3. Change the position of ADD switch 1 (only matters on the master, but might as well do it on all)
  4. Toggle the power switches back on, starting from the last slave battery
  5. Hold the SW switch on the master for 0.5s
    All the lights on all the batteries should now come on in sequence, indicating that communications between the batteries is working.

If it was indeed a baud rate issue the inverter should now see the batteries again. If it didn’t help, then repeat all the steps again. If it still doesn’t work, then I would look for loose connections one last time before looking for the issue on the inverter - perhaps it lost its settings during the power cycle. I am not familiar with that inverter model, so I can’t be of much help there.

On the old picture, you have the bms connected to rs485. On the new picture, this bms cable is missing.

Was this connected afterwards.

Pylontechs come new with about 50% charge so it’s quicker to discharge the old batteries to 50% and then connect them together to balance or fully charge the old bank then fully charge the new battery and connect them up.

If I read his original post correctly the old batteries were at 100% and the new one at the usual ±50% when they were connected together. I’ve always been too scared to do this, but according to Pylontech you can safely connect batteries with different charge levels together as long as you give them time to balance out before switching on the inverter/charger. Here’s a bit from one of their brochures:


I believe this is possible due to the “soft start” feature of the C series batteries.

Yes, that’s what I read as well, old being 100% and new 50. It will work, just takes a lot longer to balance compared to old and new.

I recently added 2 up5000 batteries to my bank of 4x us3000 and 1 ip5000. So I charged the old fully, then disconnected them, connected just to 2 new up5000 and charged them. This is on 2 sunsynk 5kw so I disconnected the load side before doing this to avoid the batteries being overloaded.

Once charged, disconnected the inverter again, connected all batteries in paralell and all lights were lit on all batteries.

My main reason for doing this was because I didn’t want to waste my pv power during the day so I used it to charge the batteries instead of waiting a long time for batteries to balance.

Hi, Yeah I was under the impression that I had to dicconect the inverter when performing the balancing. So afterwards I reconnected the grey cable from the inverter to the rs485 socket, then the Positive power cable to the Master and the Negative power cable to the last battery.

I was wondering if pressing the SW Run button again on the Master with everything conneted to the inverter would inform the Inverter that the batteries was there? Bit scared to do anything else. I did ring the installer and waiting for a call back

All Solved. The Solar Installers rang me, got me to connect to the Inverter on my phone then did something at their end. All up and running now. Thanks everyone for the info.