Pylontech Firmware Updates (We Take No Responsibility For Any Firmware Posted Here, Choose Correct Firmware For Your Battery)

I’ve posted the latest BatteryView that I have (3.0.24). It’s from earlier this year, and is most likely no longer the latest, but it still works well enough:

I have found the service from Pylontech to be very good. I haven’t asked for BatteryView yet, but when I sent a mail to to ask for the latest firmwares they sent it to me within a day on both occasions.

Pinout for the B series:

Pinout for the C series:

And here’s a crude sketch for making up a 9-pin serial plug to RJ45 plug for the C series:

The DB-9 plug side for the B-series is the same as the C-series, but they changed the other end from RJ11 to RJ45.

You will most likely need an RS232 to USB converter unless you’re able to dig up an old laptop that still has a serial port. I recently bought this one, and it works fine (after I spent some time hunting for the Windows 10 driver):

Note: I have made up a cable for the C series, but I have not actually used it yet. Still waiting for my batteries :wink:

1 Like

Things with the batteries and so many other spares are currently getting out of hand. Apparently everything is stuck on the docks, “they” dont want to release the stock as “someone” is afraid that it might get looted. If only I can find out who “They” And “Someone is”

We tried to buy some stock including batteries from other suppliers, but they sit with the same issues. I am running out of options for replacement stock for my next few installations. If things dont change soon I am going to be in trouble.

1 Like

International chip shortage is still a big problem and looks like it will continue to be for another 6-12 months.

I have tried this cable on a UC3000C and it did not work, @CenturionSolar might be able to assist here.
Johan can you maybe share the Pinout for the rs232 to Rj45 needed to communicate with the newer Pylons.

Anyone here with a Active/Ghost account on the other side, can you please ask Youda to come visit us. I am banned from that side and cant contact him myself. I was banned for sending PM’s to guys, asking them to come visit us, my PM’s got checked… so please be warned, you might face the same consequences…

I found this image on the other forum:

It is exactly the same as the sketch above. Are you sure it is not something else? The USB to serial adapter perhaps:

Let me recheck again… The USB to serial works with the other cable… will report back soon.

Sorry, my fault, bad soldering caused the RX to hang loose in the plug…

Now it works

1 Like

More Julle,

That pinout is correct yes, however, the C battery also has a 12V wakeup pin for when the port goes into sleep mode, so the cable you made above might fail at times, but that can be fixed with a plug out, plug in.

Have a good one!


Anyone know the pinouts to make a cable like this for UP5000 yet?

Same as the Us3000c, to my knowledge


Tested. The Us3000c cable does work on the UP5000 as well.

Received all the latest firmware 2 weeks back. Cell voltages were not available after updating the US3000A’s. Mailed Pylontech again and received a new version of the US3000A firmware today. Now it seems to be working.

For those who want to try updating the firmware, do not try to update any op the A or B models with C firmware, Pylontech Warned Me that I will brick the unit of I try.

Thanks, will make one and give it a go.

This post is intended for Pylontech users and was created to assist them in updating their firmware. No derailing allowed.

Here is some of the Firmware versions I have received lately.

UP5000 only (Used because my UP5000 only charged to 67%)
UP5000.bin (224 KB)

US3000A to enable Minimum / Maximum cell voltages in Victron
us3000a_V3.4_Crc.bin (214 KB)

uo5000_us3000C_us2000C_v2.2_Crc.bin (222 KB)

Standard US3000
us3000 V2.4.bin (198.9 KB)

Standard US2000
us2000 V2.4.bin (198.6 KB)


Thanks Jaco!!

Not yet the US3000B update to allow for min/max voltages?

I believe this is for the US3000B.

1 Like

Hi Jaco,
thank you for this

I have successfully updated 4 x US3000A from version v1.3 to the one you posted - v3.4

I did not select “Clear EEPROM” but only selected the .bin file and hit “Program”

Process took around 50-60 seconds per battery (and I also discovered that I can hold my breath for the same amount of time :slight_smile: )

There is a pop-up asking about coulomb, to which I just hit OK, without entering any values (I checked and the default the value is set to “none”)

Now, in Venus it is showing additional info about the battery bank

Internally there is actually fairly good protection. The battery consists of multiple modules. The firmware is first transferred into a higher module (probably the communication module), and once the entire thing is there and the checksum has been verified, only then does the comms module program the actual BMS firmware. Therefore any communication issue whereby the firmware doesn’t make it into the battery completely will result in a failed update and the battery will not be harmed.

At least, I assume this is true for the serial update as well. There are some details in their latest documentation on doing firmware updates over the CAN-bus. And that includes specific instructions to upload the firmware, check the checksum, and then transfer to the lower modules.